~zethra/poki-launcher

91cd6af56e59bb223de1f6ccd1e3152031bd2cab — Sashanoraa 6 months ago 9136cf5
all: update dep major version

Signed-off-by: Sashanoraa <sasha@sashanoraa.gay>
M Cargo.lock => Cargo.lock +11 -11
@@ 51,9 51,9 @@ checksum = "cdb031dd78e28731d87d56cc8ffef4a8f36ca26c38fe2de700543e627f8a464a"

[[package]]
name = "bitflags"
version = "1.2.1"
version = "1.3.2"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "cf1de2fe8c75bc145a2f577add951f8134889b4795d47466a54a5c846d691693"
checksum = "bef38d45163c2f1dde094a7dfd33ccf595c92905c8f8f4fdc18d06fb1037718a"

[[package]]
name = "bitvec"


@@ 212,9 212,9 @@ dependencies = [

[[package]]
name = "dbus-codegen"
version = "0.9.1"
version = "0.10.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "a49da9fdfbe872d4841d56605dc42efa5e6ca3291299b87f44e1cde91a28617c"
checksum = "a76dc35ce83e4e9fa089b4fabe66c757b27bd504dc2179c97a01b36d3e874fb0"
dependencies = [
 "clap",
 "dbus",


@@ 263,9 263,9 @@ dependencies = [

[[package]]
name = "env_logger"
version = "0.8.4"
version = "0.9.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "a19187fea3ac7e84da7dacf48de0c45d63c6a76f9490dae389aead16c243fce3"
checksum = "0b2cf0344971ee6c64c31be0d530793fba457d322dfec2810c453d0ef228f9c3"
dependencies = [
 "atty",
 "humantime",


@@ 477,7 477,7 @@ dependencies = [
 "fuzzy-matcher",
 "lazy_static",
 "log",
 "nix 0.20.2",
 "nix 0.23.0",
 "notify",
 "rmp-serde",
 "serde 1.0.131",


@@ 595,9 595,9 @@ dependencies = [

[[package]]
name = "nix"
version = "0.20.2"
version = "0.23.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "f5e06129fb611568ef4e868c14b326274959aa70ff7776e9d55323531c374945"
checksum = "f305c2c2e4c39a82f7bf0bf65fb557f9070ce06781d4f2454295cc34b1c43188"
dependencies = [
 "bitflags",
 "cc",


@@ 704,7 704,7 @@ dependencies = [
 "lib-poki-launcher",
 "libc",
 "log",
 "nix 0.20.2",
 "nix 0.23.0",
 "once_cell",
 "poki-launcher-notifier",
 "qmetaobject",


@@ 719,7 719,7 @@ version = "0.1.0"
dependencies = [
 "anyhow",
 "libc",
 "nix 0.20.2",
 "nix 0.23.0",
 "signal-hook",
]


M lib-poki-launcher/Cargo.toml => lib-poki-launcher/Cargo.toml +1 -1
@@ 38,7 38,7 @@ rmp-serde = "0.15"
fuzzy-matcher = "0.3"
directories-next = "2.0"
lazy_static = "1.4"
nix = "0.20"
nix = "0.23"
shellexpand = "2.0"
walkdir = "2.3"
file-locker = "1.0"

M poki-krunner/Cargo.toml => poki-krunner/Cargo.toml +2 -2
@@ 14,7 14,7 @@ notify = "4.0"
shellexpand = "2.0"

[dependencies.env_logger]
version = "0.8"
version = "0.9"
default-features = false
features = ["humantime", "termcolor", "atty"]



@@ 23,4 23,4 @@ version = "0.5.0"
path = "../lib-poki-launcher"

[build-dependencies]
dbus-codegen = "0.9"
dbus-codegen = "0.10"

M poki-launcher-notifier/Cargo.toml => poki-launcher-notifier/Cargo.toml +1 -1
@@ 31,5 31,5 @@ edition = "2018"
[dependencies]
signal-hook = "0.3"
libc = "0.2"
nix = "0.20"
nix = "0.23"
anyhow = "1.0"

M poki-launcher/Cargo.toml => poki-launcher/Cargo.toml +2 -2
@@ 28,7 28,7 @@ edition = "2018"

[dependencies]
libc = "0.2"
nix = "0.20"
nix = "0.23"
structopt = "0.3"
rmp-serde = "0.15"
serde_json = "1.0"


@@ 50,7 50,7 @@ path = "../poki-launcher-notifier"
version = "0.2"

[dependencies.env_logger]
version = "0.8"
version = "0.9"
default-features = false
features = ["humantime", "termcolor", "atty"]