~wintershadows/dotfiles-meta

Meta-information for dotfiles repo
880acb0d — Mysterious Grass a month ago
Add a warning about dots checkout
f2d5a13f — Mysterious Grass 3 months ago
Mention fennel req
781ac7cd — Mysterious Grass 3 months ago
Add more deps info

refs

master
browse  log 

clone

read-only
https://git.sr.ht/~wintershadows/dotfiles-meta
read/write
git@git.sr.ht:~wintershadows/dotfiles-meta

You can also use your local clone with git send-email.

#Dotfiles

#Usage

# Save the repo to `~/.dotfiles`; the `--bare` option prevents Git from making
# a mess of your home directory.
git clone --bare 'https://git.sr.ht/~wintershadows/dotfiles' ~/.dotfiles

# Set up an alias for this shell session (it's also in ~/.config/aliasrc).
alias dots='git --git-dir=$HOME/.dotfiles --work-tree=$HOME'

# Make sure we don't show untracked files in `git status` output.
dots config --local status.showUntrackedFiles no

# Checkout all local files.  # NOTE: this might overwrite existing files. Look
# before you leap. Consider checking out individual files as needed and testing
# the configuration piecemeal, instead of doing a complete checkout.
dots checkout

# Make sure we can access remotes properly. The `--bare` option requires us to
# do this manually
dots config remote.origin.fetch "+refs/heads/*:refs/remotes/origin/*"
dots fetch origin

# Set up Packer.nvim
mkdir -p ~/.local/share/nvim/site/pack/packer/opt/packer.nvim
git clone --single-branch \
	https://github.com/wbthomason/packer.nvim \
	~/.local/share/nvim/site/pack/packer/opt/packer.nvim
nvim -u NORC +'packadd packer.nvim' +PackerCompile +PackerSync

TODO: I'm not sure if my Packer setup instructions are correct, given that I have a nonstandard setup.

#Dependencies

  • Zsh
  • Neovim (must be >= v0.5 / nightly)
    • Dotfiles require Fennel, which requires Luarocks: luarocks --local --lua-version=5.1 install fennel
  • Herbstluftwm config requires:
    • Dzen2
    • Nitrogen
    • Keystatus (in src/) requires:
      • X11 ("dev")
    • Xftwidth (in src/) requires:
      • Fontconfig ("dev")
      • Freetype2 ("dev")
      • X11 ("dev")
      • Xft ("dev")
  • Tree sitter: C / C++ compiler, Libstdc++
  • Neovim-QT (optional) requires:
    • CMake
    • Qt5 ("dev")
    • Qt5Network ("dev")
    • Qt5Test ("dev")
    • Qt5Svg ("dev")

TODO: RPM and DEB for my un-packaged deps + this repo