~williewillus/patchouli

release-1.20.6-86 9 days ago .tar.gz browse log

* Update to 1.20.6
* Add advancement trigger fired when reading a book

release-1.20.4-85 3 months ago .tar.gz browse log

Updated to 1.20.4, now supporting NeoForge.

release-1.20.1-84 6 months ago .tar.gz browse log

Release 1.20.1-84
Decrease forge version requirement to 47.1.3.
No functional change on Fabric.

This is to accomodate neoforge 1.20.1 users, because the Forge and NeoForge codebases
diverge after this version.
Note though that Patchouli 1.20.1 is still targeting legacy forge in 1.20.1, and reports
related to neoforge will not be accepted until 1.20.2+, where we plan to switch to targetting neoforge.

release-1.20.1-83 7 months ago .tar.gz browse log

Release 1.20.1-83
Decrease forge version requirement to 47.1.47.
No functional change on Fabric.

This is to accomodate neoforge 1.20.1 users which don't have a 47.2.x version.
Note though that Patchouli 1.20.1 is still targeting legacy forge in 1.20.1, and reports
related to neoforge will not be accepted until 1.20.2, where we plan to switch to targetting neoforge.

release-1.20.1-82 7 months ago .tar.gz browse log

Release 1.20.1-82

* Fix model loading crash on newer Fabric API versions
* Fix focus sticking on next/previous page buttons sometimes (alcatrazEscapee)
* Various error handling improvements
  * Relation pages now fail fast when the entries are not found
  * Hide "not reloading resource pack books" log message because too many people think it's an error
  * When deserializing the "type" field of a page, use vanilla's Gson helper for better error logging
* Language improvements
  * cs_cz added (Polarni)
  * ru_ru updated (Tefny)
  * uk_ua created (unroman)
  * zh_cn updated (FinaFina)

release-1.19.4-79.1 1 year, 5 days ago .tar.gz browse log

Release 1.19.4-79.1

Fix: Book recipes causing crashes

release-1.20.1-81 1 year, 5 days ago .tar.gz browse log

Release 1.20.1-81

Change: Increase required Forge version
Fix: Book recipes causing crashes

release-1.20.1-80 1 year, 6 days ago .tar.gz browse log

Release 1.20.1-80

Change:
* Port to 1.20.1
* Resource-pack books are now required for non-external books. Additionally, extension
  books are now removed since extending can be done through the resource system. See
  https://vazkiimods.github.io/Patchouli/docs/upgrading/upgrade-guide-120/ for more
  information

Known Issues:
* "Added By" indicators for extension content will temporary show up in fewer scenarios
* Changes to smithing recipes are not fully supported yet

release-1.19.4-79 1 year, 1 month ago .tar.gz browse log

Release 1.19.4-79

* Updated to Minecraft 1.19.4
* Provide `Level` to all template component processors
* Warn when non-resource-pack books are declared

release-1.19.3-78 1 year, 5 months ago .tar.gz browse log

Release 1.19.3-78

* Expose read-only config values in API to avoid integrators digging in our internals
* Add IComponentRenderContext#navigateToEntry (Minecraftschurli)
* Update to 1.19.3 (Minecraftschurli, team)
* Update it_it translation (Blackshadow77)
1 / 7

Branches

1.19.x
0ff63c1c — Vincent Lee 7 months ago
1.20.x
a62f3fbf — Hubry 9 days ago
1.21.x
a62f3fbf — Hubry 9 days ago
gh-pages
3c8648d5 — Minecraftschurli 27 days ago
1.17-forge
d55b432e — Minecraftschurli 2 years ago
1.17-fabric
b4e6e31c — Vincent Lee 2 years ago
1.12.2-final
27ea5b52 — Vincent Lee 3 years ago
1.15-forge-final
0bd04973 — Vincent Lee 4 years ago
1.15-fabric
9a9c9888 — Vincent Lee 4 years ago
1.14-final
04651bac — Vincent Lee 4 years ago