~williewillus/botania

d46674a7949328c5d1f00c083ab01d24332af901 — Vincent Lee 3 months ago 1b4d2b7
Bump patchouli dep, reduce forge dep, align metadata with deps
M Fabric/build.gradle => Fabric/build.gradle +1 -1
@@ 107,7 107,7 @@ dependencies {

    compileOnly project(":Xplat")

    modImplementation "vazkii.patchouli:Patchouli:${minecraft_version}-81-FABRIC"
    modImplementation "vazkii.patchouli:Patchouli:${minecraft_version}-83-FABRIC"

    modCompileOnly "me.shedaniel:RoughlyEnoughItems-fabric:12.0.625"


M Fabric/src/main/resources/fabric.mod.json => Fabric/src/main/resources/fabric.mod.json +2 -2
@@ 79,8 79,8 @@

  "depends": {
    "fabricloader": ">=0.14",
    "fabric-api": ">=0.76",
    "minecraft": ">=1.19.3",
    "fabric-api": ">=0.83",
    "minecraft": ">=1.20.1 <1.21",
    "trinkets" : ">=3",
    "patchouli": "*"
  },

M Forge/build.gradle => Forge/build.gradle +2 -2
@@ 95,11 95,11 @@ minecraft {
}

dependencies {
    minecraft "net.minecraftforge:forge:${minecraft_version}-47.2.0"
    minecraft "net.minecraftforge:forge:${minecraft_version}-47.1.47"
    compileOnly project(":Xplat")
    annotationProcessor 'org.spongepowered:mixin:0.8.5:processor'

    implementation fg.deobf("vazkii.patchouli:Patchouli:${minecraft_version}-81-FORGE")
    implementation fg.deobf("vazkii.patchouli:Patchouli:${minecraft_version}-83-FORGE")
    compileOnly fg.deobf("mezz.jei:jei-1.20.1-common-api:15.2.0.27")
    runtimeOnly fg.deobf("mezz.jei:jei-1.20.1-forge:15.2.0.27")


M Forge/src/main/resources/META-INF/mods.toml => Forge/src/main/resources/META-INF/mods.toml +5 -5
@@ 1,5 1,5 @@
modLoader="javafml"
loaderVersion="[39,)"
loaderVersion="[47,)"
license="Botania License"
issueTrackerURL="https://github.com/Vazkii/Botania/issues"
logoFile="logo.png"


@@ 19,22 19,22 @@ configBackground="botania:textures/block/livingrock_bricks.png" # background for
[[dependencies.botania]]
    modId="forge"
    mandatory=true
    versionRange="[43.1.65,)"
    versionRange="[47.1.47,)"

[[dependencies.botania]]
    modId="patchouli"
    mandatory=true
    versionRange="[1.19.2-76,)"
    versionRange="[1.20.1-83,)"

[[dependencies.botania]]
    modId="curios"
    mandatory=true
    versionRange="[1.19.2-5.1.1.0,)"
    versionRange="[1.20.1-5.4.2,)"

[[dependencies.botania]]
    modId="gardenofglass"
    mandatory=false
    versionRange="[1.11,)"
    versionRange="[1.12,)"

[[dependencies.botania]]
    modId="crafttweaker"

M Xplat/build.gradle => Xplat/build.gradle +1 -1
@@ 30,7 30,7 @@ repositories {

dependencies {
    compileOnly group: 'org.spongepowered', name: 'mixin', version: '0.8.5'
    compileOnly "vazkii.patchouli:Patchouli-xplat:${minecraft_version}-81"
    compileOnly "vazkii.patchouli:Patchouli-xplat:${minecraft_version}-83"

    testImplementation 'org.junit.jupiter:junit-jupiter-api:5.6.1'
    testRuntimeOnly 'org.junit.jupiter:junit-jupiter-engine:5.6.1'