~whereiseveryone/guixrus

f3f5e855449d6c9428ded477c2396414d8551915 — jgart 1 year, 3 months ago 06d6109 tuc
add failing tuc
1 files changed, 102 insertions(+), 0 deletions(-)

A guixrus/packages/tuc.scm
A guixrus/packages/tuc.scm => guixrus/packages/tuc.scm +102 -0
@@ 0,0 1,102 @@
;;; GNU Guix --- Functional package management for GNU
;;;
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is not part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (guixrus packages tuc)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (gnu packages)
  #:use-module (gnu packages crates-io)
  #:use-module (gnu packages crates-graphics)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages tls)
  #:use-module (guixrus packages common rust)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix utils)
  #:use-module (guix build-system cargo))

(define-public rust-pico-args-0.5
  (package
    (name "rust-pico-args")
    (version "0.5.0")
    (source (origin
              (method url-fetch)
              (uri (crate-uri "pico-args" version))
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
                "05d30pvxd6zlnkg2i3ilr5a70v3f3z2in18m67z25vinmykngqav"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t))
    (home-page "https://github.com/RazrFalcon/pico-args")
    (synopsis "An ultra simple CLI arguments parser.")
    (description "An ultra simple CLI arguments parser.")
    (license license:expat)))

(define-public rust-anyhow-1
  (package
    (name "rust-anyhow")
    (version "1.0.58")
    (source (origin
              (method url-fetch)
              (uri (crate-uri "anyhow" version))
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
                "014pw61axl4idagjdh9x96b06cy12vqs5599mzi11gnd7h2x41xv"))))
    (build-system cargo-build-system)
    (arguments
     `(#:skip-build? #t
       #:cargo-inputs (("rust-backtrace" ,rust-backtrace-0.3))))
    (home-page "https://github.com/dtolnay/anyhow")
    (synopsis "Flexible concrete Error type built on std::error::Error")
    (description "Flexible concrete Error type built on std::error::Error")
    (license (list license:expat license:asl2.0))))

;;; error: failed to parse manifest at `/tmp/guix-build-tuc-0.11.0.drv-0/tuc-0.11.0/Cargo.toml`
;;; 
;;; Caused by:
;;;   feature `strip` is required
;;; 
;;;   The package requires the Cargo feature called `strip`, but that feature is not stabilized in this version of Cargo (1.57.0).
;;;   Consider trying a newer version of Cargo (this may require the nightly release).
;;;   See https://doc.rust-lang.org/nightly/cargo/reference/unstable.html#profile-strip-option for more information about the status of this feature.
;;; error: in phase 'build': uncaught exception:
;;; %exception #<&invoke-error program: "cargo" arguments: ("build" "--release") exit-status: 101 term-signal: #f stop-signal: #f>

(define-public tuc
  (package
    (name "tuc")
    (version "0.11.0")
    (source (origin
              (method url-fetch)
              (uri (crate-uri "tuc" version))
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
                "15w9ai5kngmhfax8qp0hdyjb63m7p4vs6jdxsz81l118ypvwndkg"))))
    (build-system cargo-build-system)
    (arguments
     `(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1) ("rust-pico-args" ,rust-pico-args-0.5)
                       ("rust-regex" ,rust-regex-1))
       #:cargo-development-inputs (("rust-assert-cmd" ,rust-assert-cmd-2))))
    (home-page "https://github.com/riquito/tuc")
    (synopsis "When cut doesn't cut it")
    (description "When cut doesn't cut it")
    (license license:gpl3+)))