~vpzom/lotide

affef4439b9a376ab92b6b2dca88fcf88010c41d — Colin Reeder 23 days ago b8b853d
Bump msrv to 1.47
3 files changed, 4 insertions(+), 4 deletions(-)

M Dockerfile
M clippy.toml
M doc/INSTALL.md
M Dockerfile => Dockerfile +2 -2
@@ 1,4 1,4 @@
FROM alpine:3.12 AS builder
FROM alpine:3.13 AS builder
RUN apk add --no-cache cargo openssl-dev
WORKDIR /usr/src/lotide
COPY Cargo.* ./


@@ 8,7 8,7 @@ COPY res ./res
COPY migrations ./migrations
RUN cargo build --release

FROM alpine:3.12
FROM alpine:3.13
RUN apk add --no-cache libgcc openssl
COPY --from=builder /usr/src/lotide/target/release/lotide /usr/bin/
CMD ["lotide"]

M clippy.toml => clippy.toml +1 -1
@@ 1,1 1,1 @@
msrv = "1.44.0"
msrv = "1.47.0"

M doc/INSTALL.md => doc/INSTALL.md +1 -1
@@ 1,6 1,6 @@
# lotide installation
## For production
Requirements: rustc (>=1.44.0, >=1.45.0 for hitide), cargo, openssl, and a PostgreSQL database
Requirements: rustc (>=1.47.0), cargo, openssl, and a PostgreSQL database

Set these environment variables:
 - DATABASE_URL - Credentials for database connection.