scheme-vm/compiler d---------
Refactor library import
Use dot to separate library name parts
Refactor import bindings

Stop using that silly array format
Extract file loading from Compiler
Some small fixes to loading/including libraries
Add string->symbol function
Remove unneeded instructions for if
Add symbol->string and symbol=? functions
Refactor a bit
Allow math functions to accept variable number of args
Add continuations and call/cc
Give macro definitions referential transparency

...and fix a handful of other variable and macro scoping issues
Show a helpful error if invalid instructions are detected
Start work on making library imports work
Fix bug when importing a name that doesn't exist
Add string function to base library
Rearrange vm opcodes

* Rename ops to better match how they are used.
* Arrange opcodes alphabetically because I'm tired of
  agonizing over their ordering :-)
Raise an error if two many arguments to comparison function
Remove CMP_EQV from vm -- implemented in scheme now
Move <= and >= into scheme and out of VM