~technomancy/fennel

ref: 83ccb3c3345e84c59303fcd97db257d533905399 fennel/rockspecs/fennel-0.4.0-1.rockspec -rw-r--r-- 956 bytes
83ccb3c3Phil Hagelberg Fix apropos tests for other Lua versions. 6 months ago
                                                                                
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
-- -*- lua -*-

package = "fennel"
version = "0.4.0-1"
source = {
    url = "git+https://github.com/bakpakin/Fennel",
    tag = "0.4.0"
}
description = {
   summary = "Lisp that compiles to Lua",
   detailed = [[
A lisp-like language that compiles to efficient Lua. Combine
meta-programming with Lua.]],
   homepage = "https://fennel-lang.org/",
   license = "MIT"
}
dependencies = {
   "lua >= 5.1"
}
build = {
   type = "builtin",
   modules = {
       fennel = "fennel.lua",
       fennelview = "fennelview.lua",
       fennelfriend = "fennelfriend.lua"
   },
   install = {
       bin = {
           -- use the old launcher for now; once we have a chance to mess about
           -- with the build we can try compiling the new launcher with the
           -- old; ideally during packaging time we would compile the bin/fennel
           -- script, but luarocks docs do not explain how to do this.
           fennel = "old_launcher.lua"
       }
   }
}