A pkgs/by-name/hkdf/package.nix => pkgs/by-name/hkdf/package.nix +41 -0
@@ 0,0 1,41 @@
+{
+ lib,
+ fetchFromGitHub,
+ python3,
+}:
+python3.pkgs.buildPythonPackage {
+ pname = "hkdf";
+ version = "0.0.3";
+ pyproject = true;
+
+ src = fetchFromGitHub {
+ owner = "casebeer";
+ repo = "python-hkdf";
+ rev = "cc3c9dbf0a271b27a7ac5cd04cc1485bbc3b4307";
+ hash = "sha256-i3vJzUI7dpZbgZkz7Agd5RAeWisNWftdk/mkJBZkkLg=";
+ };
+
+ build-system = [
+ python3.pkgs.setuptools
+ ];
+
+ pythonImportsCheck = [
+ "hkdf"
+ ];
+
+ nativeCheckInputs = [
+ python3.pkgs.nose
+ ];
+
+ checkPhase = ''
+ runHook preCheck
+ nosetests
+ runHook postCheck
+ '';
+
+ meta = {
+ description = "HMAC-based Extract-and-Expand Key Derivation Function (HKDF)";
+ homepage = "https://github.com/casebeer/python-hkdf";
+ license = lib.licenses.bsd2;
+ };
+}
M pkgs/by-name/vula/package.nix => pkgs/by-name/vula/package.nix +5 -2
@@ 5,6 5,7 @@
python3,
fetchgit,
highctidh,
+ hkdf,
wrapGAppsHook,
}: let
inherit
@@ 34,7 35,6 @@ in
(with python3.pkgs; [
click
cryptography
- hkdf
packaging
pillow
pydbus
@@ 48,7 48,10 @@ in
tkinter
zeroconf
])
- ++ [highctidh];
+ ++ [
+ highctidh
+ hkdf
+ ];
buildInputs = [libayatana-appindicator];
nativeBuildInputs = [wrapGAppsHook gobject-introspection];