~srushe/indieauth-token-verification

ref: 4396ba3e20b0b50d589c8b0b01e24404ccd083b5 indieauth-token-verification/indieauth-token-verification.gemspec -rw-r--r-- 1.6 KiB
4396ba3e — Stephen Rushe Add a more detailed usage example 2 years ago
                                                                                
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
# coding: utf-8
lib = File.expand_path('../lib', __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'indie_auth/token_verification/version'

Gem::Specification.new do |spec|
  spec.name          = "indieauth-token-verification"
  spec.version       = IndieAuth::TokenVerification::VERSION
  spec.authors       = ["Stephen Rushe"]
  spec.email         = ["steve+gemspec@deeden.co.uk"]

  spec.summary       = %q{Perform the access token verification portion of the IndieAuth process.}
  spec.description   = %q{Perform the access token verification portion of the IndieAuth process by communicationg with a token endpoint.}
  spec.homepage      = "https://github.com/srushe/indieauth-token-verification"
  spec.license       = "MIT"

  # Prevent pushing this gem to RubyGems.org. To allow pushes either set the 'allowed_push_host'
  # to allow pushing to a single host or delete this section to allow pushing to any host.
  if spec.respond_to?(:metadata)
    spec.metadata['allowed_push_host'] = ENV.fetch('GEMSERVER_URL', 'nohost')
  else
    raise "RubyGems 2.0 or newer is required to protect against " \
      "public gem pushes."
  end

  spec.files         = `git ls-files -z`.split("\x0").reject do |f|
    f.match(%r{^(test|spec|features)/})
  end
  spec.bindir        = "exe"
  spec.executables   = spec.files.grep(%r{^exe/}) { |f| File.basename(f) }
  spec.require_paths = ["lib"]

  spec.add_development_dependency "bundler", "~> 2.0"
  spec.add_development_dependency "climate_control"
  spec.add_development_dependency "pry"
  spec.add_development_dependency "rake", "~> 12.3"
  spec.add_development_dependency "rspec", "~> 3.0"
end