~sirn/fanboi2

fd9239b3ff5c3cb5a3bb6f9b3bd993ccfcd40bd2 — Kridsada Thanabulpong 4 years ago e28d50e
Update changelog and bump version to 0.10.1.
4 files changed, 13 insertions(+), 3 deletions(-)

M CHANGES.rst
M README.rst
M package.json
M setup.py
M CHANGES.rst => CHANGES.rst +9 -1
@@ 1,6 1,14 @@
0.10.0
0.10.1
======

- [Add] A ``board`` query string for expanding board from topic API.
- [Add] A ``topic`` query string for expanding post from post API.
- [Change] Switch to `Yarn <https://yarnpkg.com/>`_ for assets package management.
- [Change] Stylings of appendix section is now consistent with the footer.

0.10.0
------

- [Add] Basic API for board, topic and post operations.
- [Add] Dark theme ("Obsidian").
- [Add] Banning rules allowing an IP address to be blocked.

M README.rst => README.rst +2 -0
@@ 104,3 104,5 @@ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND 

.. _Vagrant: https://www.vagrantup.com/
.. _Yarn: https://yarnpkg.com/
.. _Gulp: http://gulpjs.com/
.. _Typings: https://github.com/typings/typings

M package.json => package.json +1 -1
@@ 2,7 2,7 @@
  "author": "Kridsada Thanabulpong",
  "name": "fanboi2",
  "description": "Assets for Fanboi2 board app",
  "version": "0.10.0",
  "version": "0.10.1",
  "repository": "https://github.com/pxfs/fanboi2.git",
  "license": "BSD-3-Clause",
  "dependencies": {

M setup.py => setup.py +1 -1
@@ 42,7 42,7 @@ requires = [
    ]

setup(name='fanboi2',
      version='0.10.0',
      version='0.10.1',
      description='fanboi2',
      long_description=readme + '\n\n' + changes,
      classifiers=[