fix typo in quoted reply template
templates: fixup error in template modification

The change of WrapText --> Wrap left the order of the arguments unchanged, which
is wrong.
templates: Use wrap instead of wrapText

bf0f72a533d5 ("template: add exec and wrap") introduced wrap which
allowed to chain wrapText. It also changed the aerc-templates man page
to document wrap instead of wrapText. The templates weren't updated
then, so update now.
add mimeType to OriginalMail struct for both forward and reply
FindFirstNonMultipart: return the proper path

There was a bug that lead to the wrong path being returned by the function.
send: fix missing error return
Fix linter warnings

* Remove redundant return (code was never reached)
* Remove redundant type information
* Rename unused function parameters to "_"
lib/parse: simplify parseAddressList
aerc: try to recover from a panic

As of now we crash fairly often. The problem is that we didn't run the cleanup
routine of the ui in this case, leaving the pty in a bad state.
Instead, recover from a panic and at least try to run the ui deinit.
maildir: don't read the full file into memory
notmuch: don't read the full file into memory
Makefile: use git version string if we can

Some packagers overwrote the version we embed in aerc, we really don't want that.
Hence we force clear the variable at the beginning of the makefile.
If git is available and returns a useful info we now use that version instead
of the hardcoded version
terminal: Add support for Shift+Tab
send: fix crash if invalid password is given
Get rid of the aerc.PushError(" " + $string) idiom

The individual callers should not be responsible for padding
Refactor lib/open to accept user provided arguments

* Get rid of open_darwin
	It just lead to code duplication for a simple one string change.
	Instead we query it during initialization
* Accept user provided arguments
	"open" on MacOS accepts things like -A to use a specific application
	Pass trough arguments the user provided in order to facilitate this
* Refactor the function to a struct
	This makes it more convenient for the caller and avoids signatures like
	lib.OpenFile(nil, u.String(), nil) which are fairly unreadable
send: don't block the UI thread during the sending
save: if part name is a path, only use the filename
bbe8ba5b — Bor Grošelj Simić a month ago
correct permission check on accounts.conf
compose: apply default style to header separator
trim <> from messageIDs when handling mailto links

Co-authored-by: James Walmsley <james@fullfat-fs.co.uk>