M .SRCINFO => .SRCINFO +6 -7
@@ 1,15 1,14 @@
pkgbase = php-cs-fixer
pkgdesc = Analyzes some PHP source code and tries to fix coding standards issues (PSR-1 and PSR-2 compatible).
- pkgver = 3.17.0
+ pkgver = 3.26.0
pkgrel = 1
url = https://github.com/PHP-CS-Fixer/PHP-CS-Fixer
arch = any
license = MIT
- makedepends = php-box
- makedepends = composer
- makedepends = git
- depends = php>=7.1.3
- source = php-cs-fixer::git+https://github.com/PHP-CS-Fixer/PHP-CS-Fixer#tag=v3.17.0
- md5sums = SKIP
+ conflicts = php-cs-fixer-git
+ source = php-cs-fixer.phar::https://github.com/PHP-CS-Fixer/PHP-CS-Fixer/releases/download/v3.26.0/php-cs-fixer.phar
+ source = LICENSE
+ sha256sums = eb5525d55fe845b423da9d8b327ff0dd5a20025d03cddaa08aec95fbef6b2501
+ sha256sums = 2328ecf7ed904804f5e9f9c70762d2e0baf6610d872c611bbddca94baa970549
pkgname = php-cs-fixer
A .gitignore => .gitignore +4 -0
@@ 0,0 1,4 @@
+*.phar
+*.pkg.tar.*
+/pkg/
+/src/
A LICENSE => LICENSE +19 -0
@@ 0,0 1,19 @@
+Copyright (c) 2012+ Fabien Potencier, Dariusz Rumiński
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is furnished
+to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
M PKGBUILD => PKGBUILD +12 -16
@@ 1,31 1,27 @@
# Maintainer: Bruno Galeotti <bgaleotti at gmail dot com>
# Co-Mantainer: Stefan Auditor <stefan@auditor.email>
+# Mantainer: Shulhan <ms@kilabit.info>
_pkgname=php-cs-fixer
pkgname=${_pkgname}
-pkgver=3.17.0
+pkgver=3.26.0
pkgrel=1
pkgdesc="Analyzes some PHP source code and tries to fix coding standards issues (PSR-1 and PSR-2 compatible)."
url="https://github.com/PHP-CS-Fixer/PHP-CS-Fixer"
+conflicts=(php-cs-fixer-git)
license=("MIT")
arch=("any")
-depends=("php>=7.1.3")
-makedepends=("php-box" "composer" "git")
-source=("${_pkgname}::git+https://github.com/PHP-CS-Fixer/PHP-CS-Fixer#tag=v${pkgver}")
-md5sums=('SKIP')
-
-prepare() {
- cd "${srcdir}/${_pkgname}"
- composer install --no-interaction
-}
-
-build() {
- cd "${srcdir}/${_pkgname}"
- box compile --no-interaction
-}
+source=(
+ "${_pkgname}.phar::https://github.com/PHP-CS-Fixer/PHP-CS-Fixer/releases/download/v${pkgver}/php-cs-fixer.phar"
+ 'LICENSE'
+)
+sha256sums=(
+ 'eb5525d55fe845b423da9d8b327ff0dd5a20025d03cddaa08aec95fbef6b2501'
+ '2328ecf7ed904804f5e9f9c70762d2e0baf6610d872c611bbddca94baa970549'
+)
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/"
install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
install -D -m755 "${_pkgname}.phar" "${pkgdir}/usr/bin/${_pkgname}"
}