M .SRCINFO => .SRCINFO +5 -3
@@ 1,6 1,6 @@
pkgbase = google-compute-engine-oslogin
pkgdesc = OS Login Guest Environment for Google Compute Engine
- pkgver = 20220721.00
+ pkgver = 20230831.00
pkgrel = 1
url = https://github.com/GoogleCloudPlatform/guest-oslogin
install = google-compute-engine-oslogin.install
@@ 10,9 10,11 @@ pkgbase = google-compute-engine-oslogin
depends = curl
depends = json-c
depends = pam
- source = google-compute-engine-oslogin-20220721.00.tar.gz::https://github.com/GoogleCloudPlatform/guest-oslogin/archive/20220721.00.tar.gz
+ source = google-compute-engine-oslogin-20230831.00.tar.gz::https://github.com/GoogleCloudPlatform/guest-oslogin/archive/20230831.00.tar.gz
source = google-compute-engine-oslogin.install
- sha256sums = 17a0cd15df917c6ae29daa299d04e2e95e8b891918d2976b31b6c13398f0bc37
+ source = test-Makefile.patch
+ sha256sums = 06690c9eb19916320b85437de79016c9788c3007e88f69b11d81a466a583a5e5
sha256sums = 3e488f66f6ddc5882d731bd951391efe588c1fbb19afcf4de5283ec7fd481039
+ sha256sums = ae2c8b6ef1a9b264d7cf07ca328cc181e72c346cdf61a4b5dfae4350dce5d793
pkgname = google-compute-engine-oslogin
M PKGBUILD => PKGBUILD +17 -5
@@ 14,9 14,10 @@
# Maintainer: Lorenzo Castelli <lcastelli@google.com>
# Maintainer: Samuel Littley <samuellittley@google.com>
+# Maintainer: Shulhan <ms@kilabit.info>
pkgname='google-compute-engine-oslogin'
-pkgver=20220721.00
+pkgver=20230831.00
pkgrel=1
pkgdesc='OS Login Guest Environment for Google Compute Engine'
arch=('x86_64')
@@ 24,10 25,16 @@ url='https://github.com/GoogleCloudPlatform/guest-oslogin'
license=('Apache')
depends=('curl' 'json-c' 'pam')
checkdepends=('gtest')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/guest-oslogin/archive/$pkgver.tar.gz"
- 'google-compute-engine-oslogin.install')
-sha256sums=('17a0cd15df917c6ae29daa299d04e2e95e8b891918d2976b31b6c13398f0bc37'
- '3e488f66f6ddc5882d731bd951391efe588c1fbb19afcf4de5283ec7fd481039')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/GoogleCloudPlatform/guest-oslogin/archive/$pkgver.tar.gz"
+ 'google-compute-engine-oslogin.install'
+ 'test-Makefile.patch'
+)
+sha256sums=(
+ '06690c9eb19916320b85437de79016c9788c3007e88f69b11d81a466a583a5e5'
+ '3e488f66f6ddc5882d731bd951391efe588c1fbb19afcf4de5283ec7fd481039'
+ 'ae2c8b6ef1a9b264d7cf07ca328cc181e72c346cdf61a4b5dfae4350dce5d793'
+)
install='google-compute-engine-oslogin.install'
build() {
@@ 35,6 42,11 @@ build() {
make
}
+prepare() {
+ cd "guest-oslogin-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/test-Makefile.patch"
+}
+
check() {
cd "guest-oslogin-$pkgver"
make GTEST_DIR=/usr/src/googletest non_network_tests
A test-Makefile.patch => test-Makefile.patch +12 -0
@@ 0,0 1,12 @@
+diff --unified --recursive --text guest-oslogin-20230831.00.orig/test/Makefile guest-oslogin-20230831.00/test/Makefile
+--- guest-oslogin-20230831.00.orig/test/Makefile 2023-09-06 20:09:31.012911218 +0700
++++ guest-oslogin-20230831.00/test/Makefile 2023-09-06 20:09:39.396267643 +0700
+@@ -8,7 +8,7 @@
+ NEW_TEST_RUNNER = ./new_test_runner --gtest_output=xml
+ SSHCA_TEST_RUNNER = ./sshca_runner --gtest_output=xml --gtest_filter="SSHCATests.*"
+ CPPFLAGS += -I$(TOPDIR)/src/include -I$(TOPDIR)/third_party/include -I/usr/include/json-c -I$(GTEST_DIR) -isystem $(GTEST_DIR)/include
+-CXXFLAGS += -g -Wall -Wextra -std=c++11
++CXXFLAGS += -g -Wall -Wextra -std=c++14
+ LDLIBS = -lcurl -ljson-c -lpthread
+
+ .PHONY: all clean alltests ping reset