M debian/control => debian/control +20 -1
@@ 15,7 15,7 @@ Build-Depends:
python-sphinx,
python-coverage,
python3-coverage,
- locales-all,
+ locales-all
Standards-Version: 3.9.8
X-Python-Version: >= 2.6
X-Python3-Version: >= 3.4
@@ 26,6 26,7 @@ Vcs-Browser: https://anonscm.debian.org/cgit/python-modules/packages/kitchen.git
Package: python-kitchen
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}
+Suggests: python-kitchen-doc
Description: Python library of containers, text and i18n helpers (Python 2)
The kitchen Python package aims at gathering in one place all the snippets of
code that the author originally carried around from project to project to ease
@@ 42,6 43,7 @@ Description: Python library of containers, text and i18n helpers (Python 2)
Package: python3-kitchen
Architecture: all
Depends: ${misc:Depends}, ${python3:Depends}
+Suggests: python-kitchen-doc
Description: Python library of containers, text and i18n helpers (Python 3)
The kitchen Python package aims at gathering in one place all the snippets of
code that the author originally carried around from project to project to ease
@@ 54,3 56,20 @@ Description: Python library of containers, text and i18n helpers (Python 3)
* Tools to help deal with PEP386 version format
.
This package installs the library for Python 3.
+
+Package: python-kitchen-doc
+Architecture: all
+Section: doc
+Depends: ${sphinxdoc:Depends}, ${misc:Depends}
+Description: Python library of containers, text and i18n helpers (common documentation)
+ The kitchen Python package aims at gathering in one place all the snippets of
+ code that the author originally carried around from project to project to ease
+ the development.
+ .
+ A non-exhaustive list of the features provided by kitchen:
+ * helpers for text and specifically unicode handling i18n support
+ * a dictionary that treats unicode and str strings as different values
+ * An helper function to change any non-list value into a single-element list
+ * Tools to help deal with PEP386 version format
+ .
+ This is the common documentation package.
A debian/python-kitchen-doc.doc-base => debian/python-kitchen-doc.doc-base +21 -0
@@ 0,0 1,21 @@
+Document: kitchen
+Title: Debian kitchen Manual
+Author: Toshio Kuratomi
+Abstract: This is the manual for kitchen.
+ kitchen is a Python plugin that aims at gathering in one place all
+ the snippets of code that the author originally carried around from
+ project to project to ease the development.
+ .
+ A non-exhaustive list of the features provided by kitchen:
+ * helpers for text and specifically unicode handling i18n support
+ * a dictionary that treats unicode and str strings as different values
+ * An helper function to change any non-list value into a single-element list
+ * Tools to help deal with PEP386 version format
+Section: Programming/Python
+
+Format: HTML
+Index: /usr/share/doc/python-kitchen-doc/html/index.html
+Files:
+ /usr/share/doc/python-kitchen-doc/html/*.html
+ /usr/share/doc/python-kitchen-doc/html/_sources/*
+ /usr/share/doc/python-kitchen-doc/html/_static/*
A debian/python-kitchen-doc.docs => debian/python-kitchen-doc.docs +2 -0
@@ 0,0 1,2 @@
+kitchen2/docs/_build/html/
+NEWS.rst
A debian/python-kitchen-doc.manpages => debian/python-kitchen-doc.manpages +1 -0
@@ 0,0 1,1 @@
+kitchen2/docs/_build/man/kitchen.1
M debian/rules => debian/rules +9 -0
@@ 9,3 9,12 @@ export LANGUAGE =
%:
dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
+
+override_dh_auto_build:
+ dh_auto_build
+# Docs from kitchen2 and kitchen3 are basically the same, so we just
+# use the ones from kitchen2.
+ PYTHONPATH=$(CURDIR)/kitchen2/ http_proxy='127.0.0.1:9' \
+ sphinx-build -N -bhtml kitchen2/docs/ kitchen2/docs/_build/html
+ PYTHONPATH=$(CURDIR)/kitchen2/ http_proxy='127.0.0.1:9' \
+ sphinx-build -N -bman kitchen2/docs/ kitchen2/docs/_build/man