~robertgzr/portage

ca1a6608e72600a69d0f24c9d6d68c6801577d1a — Robert Günzler 4 months ago d309a12
add mpv-plugin/thumbfast

Signed-off-by: Robert Günzler <r@gnzler.io>
1 files changed, 32 insertions(+), 0 deletions(-)

A mpv-plugin/thumbfast/thumbfast-9999.ebuild
A mpv-plugin/thumbfast/thumbfast-9999.ebuild => mpv-plugin/thumbfast/thumbfast-9999.ebuild +32 -0
@@ 0,0 1,32 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

USE_MPV="rdepend"
MPV_REQ_USE="lua"
inherit mpv-plugin

DESCRIPTION="High-performance on-the-fly thumbnailer"
HOMEPAGE="https://github.com/po5/thumbfast"

if [[ $PV = *9999* ]]; then
	inherit git-r3
	EGIT_REPO_URI="https://github.com/po5/thumbfast"
else
	SRC_URI="https://github.com/po5/thumbfast/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
fi


LICENSE="GPL-3"
KEYWORDS="~amd64"

src_prepare() {
	default

	mkdir -p ${PN}/script-opts
	mv ./${PN}.conf ./${PN}/script-opts/
	mv ./${PN}.lua ./${PN}/main.lua
}

MPV_PLUGIN_FILES=( ${PN} )