~robertgzr/portage

4b26dfc64087efd44d0f59ac7dafa2a1e6998653 — Robert Günzler 4 months ago ca1a660
add app-misc/timetrace

Signed-off-by: Robert Günzler <r@gnzler.io>
1 files changed, 25 insertions(+), 0 deletions(-)

A app-misc/timetrace/timetrace-9999.ebuild
A app-misc/timetrace/timetrace-9999.ebuild => app-misc/timetrace/timetrace-9999.ebuild +25 -0
@@ 0,0 1,25 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go

DESCRIPTION="simple cli for tracking working time"
HOMEPAGE="https://github.com/dominikbraun/timetrace"

inherit git-r3
EGIT_REPO_URI="https://github.com/dominikbraun/timetrace.git"

RESTRICT="network-sandbox strip"
LICENSE="MIT"
SLOT="0"
IUSE=""
KEYWORDS="~amd64 ~arm64 ~x86"

src_unpack() {
	default
	git-r3_src_unpack
	cd ${S} && sed -i -e 's/go 1.15/go 1.18/' ${S}/go.mod && go mod tidy
	go-module_live_vendor
}