~robertgzr/portage

1390d39938dd413fc299e372d156beb5595230c7 — Robert Günzler 10 months ago 0e50765
app-emulation/quickemu: bump to 4.9.1
2 files changed, 49 insertions(+), 0 deletions(-)

A app-emulation/quickemu/Manifest
A app-emulation/quickemu/quickemu-4.9.1.ebuild
A app-emulation/quickemu/Manifest => app-emulation/quickemu/Manifest +2 -0
@@ 0,0 1,2 @@
DIST quickemu-4.8.tar.gz 166544 BLAKE2B 527ce0cb7310d4d4f3ce19900a60b40b1534a637c58899beb48a947b4bd29c02c8381af65b966f205883c811219cadd2c6dcb40d5bb6925ed92db4283b7d1d4c SHA512 1f09e99ac4e508d5fe9e26482bd6b318f4cc0256bb8079799dc162ea5789ca99a07a11af283456f7832eed0c970ec0dae46e3ab2e80696954f16ff6807e32765
DIST quickemu-4.9.1.tar.gz 176739 BLAKE2B 0cb89afcc54e9e35573721a45a381be708843d33a70d6b8ed9943b46922dc584ff12a34414fc421f85ffc23eb335185d210f126b4bf77c6fa37a02e64ab13c4a SHA512 bf6e4f8a4d05ceb1b69eb32041476d91275c302de162a578380183d981625837256dd7b06804920cf17215657ad4c19eb75ffa12d071cef01d0baabffcc79479

A app-emulation/quickemu/quickemu-4.9.1.ebuild => app-emulation/quickemu/quickemu-4.9.1.ebuild +47 -0
@@ 0,0 1,47 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_10 )
inherit python-single-r1

DESCRIPTION="Create and run optimised Windows, macOS and Linux desktop virtual machines"
HOMEPAGE="https://github.com/quickemu-project/quickemu"
SRC_URI="https://github.com/quickemu-project/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="zsync tpm X"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DEPEND="
	${PYTHON_DEPS}
	>=app-emulation/qemu-6.0.0[gtk,sdl,spice,smartcard,usbredir,virgl,virtfs]
	>=app-shells/bash-4.0:=
	app-cdr/cdrtools
	tpm? ( app-crypt/swtpm )
	app-misc/jq
	app-emulation/spice[smartcard]
	net-misc/spice-gtk[gtk3,smartcard,usbredir]
	net-misc/wget
	zsync? ( net-misc/zsync )
	sys-apps/usbutils
	sys-apps/util-linux
	|| (
		sys-firmware/edk2-ovmf
		sys-firmware/edk2-ovmf-bin
	)
	sys-process/procps
	X? ( x11-apps/xrandr )
	x11-misc/xdg-user-dirs
"
RDEPEND="${DEPEND}"
BDEPEND=""

src_install() {
	python_doscript macrecovery macrecovery
	dobin quickemu
	dobin quickget
}