~rjarry/aerc

ref: 602a5778e872cf18935433b2916b0e4a54f5fcea aerc/.builds/alpine-edge.yml -rw-r--r-- 584 bytes
602a5778 — Moritz Poldrack go: bumped minimum required version 1.16 2 months ago
                                                                                
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
---
image: alpine/edge
packages:
  - go
  - gnupg
  - notmuch-dev
  - scdoc
sources:
  - "https://git.sr.ht/~rjarry/aerc"
environment:
  DESTDIR: ./out
  GOFLAGS: "-tags=notmuch"
tasks:
  - lint: |
      cd aerc
      make lint
  - build: |
      cd aerc
      make
  - install: |
      cd aerc
      make install
      make checkinstall
  - test: |
      cd aerc
      go test ./...
  - ancient-go-version: |
      curl -O https://dl-cdn.alpinelinux.org/alpine/v3.14/community/x86_64/go-1.16.15-r0.apk
      sudo apk add ./go-1.16.15-r0.apk
      cd aerc
      make clean
      make