~pmikkelsen/apl2048

Rename shift to remove
Simplify newgame function
Move newnumber to seperate function, and simplify shift
Remove combine function
Simplify combine function
Move code to swipeup as it fits better there