~nhanb/pytaku

ref: 67d3b85822336dedd5a579404f39bddd44a5c7ba pytaku/pyproject.toml -rw-r--r-- 1.0 KiB
67d3b858Bùi Thành Nhân update demo url 2 months ago
                                                                                
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
[tool.poetry]
name = "pytaku"
version = "0.6.2"
description = "Self-hostable web-based manga reader"
authors = ["Bùi Thành Nhân <hi@imnhan.com>"]
license = "AGPL-3.0-only"
readme = "README.md"
packages = [
    { include = "pytaku", from = "src" },
    { include = "mangoapi", from = "src" },
]
# Compiled js bundle dir is in gitignore, which poetry also reads.
# Therefore, it needs to be specifically whitelisted here:
include = ["src/pytaku/static/js/*"]

[tool.poetry.scripts]
pytaku = "pytaku:serve"
pytaku-dev = "pytaku:dev"
pytaku-migrate = "pytaku:migrate"
pytaku-generate-config = "pytaku:generate_config"
pytaku-scheduler = "pytaku:scheduler"
pytaku-collect-static = "pytaku:collect_static"

[tool.poetry.dependencies]
python = "^3.7"
flask = "^1.1.2"
gunicorn = "^20.0.4"
requests = "^2.24.0"
goodconf = "^1.0.0"
argon2-cffi = "^20.1.0"
bbcode = "^1.1.0"

[tool.poetry.dev-dependencies]
pytest = "^6.0.1"
ipdb = "^0.13.3"

[build-system]
requires = ["poetry>=0.12"]
build-backend = "poetry.masonry.api"

[tool.black]
line-length = 88
target-version = ['py37']