~naglis/aio_mpv_ipc

423b236bea3fdf7eb44621e35e7bb64669e5b86e — Naglis Jonaitis 1 year, 3 months ago 48b238f
Bump Python version
3 files changed, 4 insertions(+), 61 deletions(-)

M .github/workflows/ci.yml
M poetry.lock
M pyproject.toml
M .github/workflows/ci.yml => .github/workflows/ci.yml +1 -1
@@ 6,7 6,7 @@ jobs:
    strategy:
      fail-fast: false
      matrix:
        python: ['3.7']
        python: ['3.8']
    steps:
      - uses: actions/checkout@v1


M poetry.lock => poetry.lock +2 -59
@@ 207,10 207,6 @@ version = "2.3.0"
cached-property = ">=1.0.0,<2.0.0"
flake8 = "!=3.2.0"

[package.dependencies.importlib-metadata]
python = "<3.8"
version = "*"

[[package]]
category = "dev"
description = "Git Object Database"


@@ 254,22 250,6 @@ version = "2.8"

[[package]]
category = "dev"
description = "Read metadata from Python packages"
marker = "python_version < \"3.8\""
name = "importlib-metadata"
optional = false
python-versions = "!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*,>=2.7"
version = "1.3.0"

[package.dependencies]
zipp = ">=0.5"

[package.extras]
docs = ["sphinx", "rst.linker"]
testing = ["packaging", "importlib-resources"]

[[package]]
category = "dev"
description = "McCabe checker, plugin for flake8"
name = "mccabe"
optional = false


@@ 320,11 300,6 @@ optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "0.13.1"

[package.dependencies]
[package.dependencies.importlib-metadata]
python = "<3.8"
version = ">=0.12"

[package.extras]
dev = ["pre-commit", "tox"]



@@ 346,10 321,6 @@ six = "*"
toml = "*"
virtualenv = ">=15.2"

[package.dependencies.importlib-metadata]
python = "<3.8"
version = "*"

[[package]]
category = "dev"
description = "library with cross-python path, ini-parsing, io, code, log facilities"


@@ 400,10 371,6 @@ pluggy = ">=0.12,<1.0"
py = ">=1.5.0"
wcwidth = "*"

[package.dependencies.importlib-metadata]
python = "<3.8"
version = ">=0.12"

[package.extras]
testing = ["argcomplete", "hypothesis (>=3.56)", "mock", "nose", "requests", "xmlschema"]



@@ 531,25 498,9 @@ optional = false
python-versions = "*"
version = "0.1.7"

[[package]]
category = "dev"
description = "Backport of pathlib-compatible object wrapper for zip files"
marker = "python_version < \"3.8\""
name = "zipp"
optional = false
python-versions = ">=2.7"
version = "0.6.0"

[package.dependencies]
more-itertools = "*"

[package.extras]
docs = ["sphinx", "jaraco.packaging (>=3.2)", "rst.linker (>=1.9)"]
testing = ["pathlib2", "contextlib2", "unittest2"]

[metadata]
content-hash = "cc8b5fa855fc6cb4101e68b5f9c67f5b57cd3fc05dd41e962d3b7a0b4f348918"
python-versions = "^3.7"
content-hash = "7615c10c0625943b2a9ee765f6e9efab12e2ff6add3666297a2760f7c50aade5"
python-versions = "^3.8"

[metadata.files]
appdirs = [


@@ 673,10 624,6 @@ idna = [
    {file = "idna-2.8-py2.py3-none-any.whl", hash = "sha256:ea8b7f6188e6fa117537c3df7da9fc686d485087abf6ac197f9c46432f7e4a3c"},
    {file = "idna-2.8.tar.gz", hash = "sha256:c357b3f628cf53ae2c4c05627ecc484553142ca23264e593d327bcde5e9c3407"},
]
importlib-metadata = [
    {file = "importlib_metadata-1.3.0-py2.py3-none-any.whl", hash = "sha256:d95141fbfa7ef2ec65cfd945e2af7e5a6ddbd7c8d9a25e66ff3be8e3daf9f60f"},
    {file = "importlib_metadata-1.3.0.tar.gz", hash = "sha256:073a852570f92da5f744a3472af1b61e28e9f78ccf0c9117658dc32b15de7b45"},
]
mccabe = [
    {file = "mccabe-0.6.1-py2.py3-none-any.whl", hash = "sha256:ab8a6258860da4b6677da4bd2fe5dc2c659cff31b3ee4f7f5d64e79735b80d42"},
    {file = "mccabe-0.6.1.tar.gz", hash = "sha256:dd8d182285a0fe56bace7f45b5e7d1a6ebcbf524e8f3bd87eb0f125271b8831f"},


@@ 778,7 725,3 @@ wcwidth = [
    {file = "wcwidth-0.1.7-py2.py3-none-any.whl", hash = "sha256:f4ebe71925af7b40a864553f761ed559b43544f8f71746c2d756c7fe788ade7c"},
    {file = "wcwidth-0.1.7.tar.gz", hash = "sha256:3df37372226d6e63e1b1e1eda15c594bca98a22d33a23832a90998faa96bc65e"},
]
zipp = [
    {file = "zipp-0.6.0-py2.py3-none-any.whl", hash = "sha256:f06903e9f1f43b12d371004b4ac7b06ab39a44adc747266928ae6debfa7b3335"},
    {file = "zipp-0.6.0.tar.gz", hash = "sha256:3718b1cbcd963c7d4c5511a8240812904164b7f381b647143a89d3b98f9bcd8e"},
]

M pyproject.toml => pyproject.toml +1 -1
@@ 11,7 11,7 @@ classifiers = [
]

[tool.poetry.dependencies]
python = "^3.7"
python = "^3.8"

[tool.poetry.dev-dependencies]
flake8 = "^3.7"