merge from upstream
1b9540cc — dannye 4 months ago
Update `EndBug` to v9.
17eaf761 — Vortyne 5 months ago
Name some unnamed animation constants (#396)

a76ae055 — RainbowMetalPigeon 5 months ago
Dex weights are in tenths of a pound

we have stdnoreturn.h now
build on plan9
5c4795d5 — SatoMew 6 months ago
Complete and improve debug name labels (#408)

e076ee0a — dannye 8 months ago
Add list assertion to TrainerNames
20ebfd07 — vulcandth 8 months ago
Add table assertion to `TrainerDataPointers` (#403)

* Add table assertion to `TrainerDataPointers`

* Add table assertion to `TrainerNamePointers`
Use rgbds 0.6.1 (0.6.0 also still works)
Fix preinclude dependencies

From pokecrystal:
- 0425018d1ce5b3b726e3cd83f59f14ead9171c92
- 8b429e2a545e87407a3b8c7b92f7ceafc455e390
Add `COUNTOF` macro to tools/common.h
Update tools/unnamed.py for rgbds 0.6.0 object files
Require rgbds 0.6.0
`startswith` works with a tuple
Revert PR #395
742dd00e — Vortyne 11 months ago
Bug: Sprites can receive the wrong movement byte (#395)

Co-authored-by: Rangi <35663410+Rangi42@users.noreply.github.com>
3e72d083 — Vortyne 11 months ago

Co-authored-by: Rangi <35663410+Rangi42@users.noreply.github.com>
0f5a9eb1 — BlueZangoose 11 months ago
Change names of move subanimations to be meaningful (#389)

Co-authored-by: Rangi <remy.oukaour+rangi42@gmail.com>
Use a SPRITE_SET_LENGTH constant