~misterio/nur-packages

3b1ab19301157e679f73bb0c3ddfd630094c255f — Gabriel Fontes 2 years ago e118f50
argononed: don't add i2c dt, nixos-hardware now has a module for that
1 files changed, 2 insertions(+), 17 deletions(-)

M modules/hardware/argonone.nix
M modules/hardware/argonone.nix => modules/hardware/argonone.nix +2 -17
@@ 13,6 13,8 @@ in {
      defaultText = "nur.argononed";
      description = ''
        The package implementing the Argon One driver

        Do note you need i2c enabled for this to work. Importing the rpi4 module from nixos-hardware should do the trick. 
      '';
    };
  };


@@ 24,23 26,6 @@ in {
        name = "argononed";
        dtboFile = "${cfg.package}/boot/overlays/argonone.dtbo";
      }
      # Seems to be absolutely needed for pi4
      {
          name = "i2c0";
          dtsText = ''
    /dts-v1/;
          /plugin/;
          /{
              compatible = "raspberrypi,4-model-b";
              fragment@1 {
                  target = <&i2c1>;
                  __overlay__ {
                      status = "okay";
                  };
              };
          };
          '';
      }
    ];
    environment.systemPackages = [ cfg.package ];
    systemd.services.argononed = {