~lthms/ogmios

4b6051643288e2a5c4b162695baf5655f3947009 — Thomas Letan 1 year, 7 months ago f7518cf
deps: rocket_codegen shall not be a direct dependency anymore

See the ChangeLog[¶] of rocket-0.4.0-rc.1 for more information about
this change. Considering all rocket project had to depend on it, I
would say it is a very good move.

[¶]: https://github.com/SergioBenitez/Rocket/blob/v0.4/CHANGELOG.md#codegen-rewrite
2 files changed, 0 insertions(+), 2 deletions(-)

M Cargo.lock
M Cargo.toml
M Cargo.lock => Cargo.lock +0 -1
@@ 624,7 624,6 @@ dependencies = [
 "ogmarkup 0.1.0 (git+https://git.sr.ht/~lthms/ogmarkup/?rev=34d0cd8fa896ff08dad47954491bc7edbd160437)",
 "pretty_env_logger 0.2.5 (registry+https://github.com/rust-lang/crates.io-index)",
 "rocket 0.4.0-rc.1 (registry+https://github.com/rust-lang/crates.io-index)",
 "rocket_codegen 0.4.0-rc.1 (registry+https://github.com/rust-lang/crates.io-index)",
 "rocket_contrib 0.4.0-rc.1 (registry+https://github.com/rust-lang/crates.io-index)",
 "serde 1.0.80 (registry+https://github.com/rust-lang/crates.io-index)",
 "serde_derive 1.0.80 (registry+https://github.com/rust-lang/crates.io-index)",

M Cargo.toml => Cargo.toml +0 -1
@@ 8,7 8,6 @@ error-chain       = "0.12"
log               = "0.4"
pretty_env_logger = "0.2"
rocket            = "0.4.0-rc.1"
rocket_codegen    = "0.4.0-rc.1"
serde             = "1.0"
serde_derive      = "1.0"
serde_json        = "1.0"