~leon_plickat/lavalauncher

Bumb version to 2.0.0
Add "./lavalauncher.conf" as additonal default config location

This makes testing a lot easier.
Improve phrasing of README, CONTRIBUTING and man page
Remove foreign-toplevel-management support

For something like LavaLauncher it makes more sense to encourage the
usage of stand-alone tools for things like this, which will work just as
well and are more flexible, as the toplevel operations can be controlled
by the shell commands.
Better error messages for config errors
Make margins uint32_t
remove .direction from bar-pattern configuration mechanism

And sort the struct array.
simplify directional config options

Instead of having 5 options, config options which are optionally
directional now have only 1.
man-page: Simplify syntax explanation and example config
Rewrite parser_get_string()

String reading in the config now works like one usually expects from
Linux / UNIX applications.
Implement (some) backslash escape sequences for strings
Create indicators for touchpoints
Implement touchpoint_from_id()
Handle touch cancel event

The cancel event means that the compositor has decided to take over the
touch-input, possibly for gestures, and that therefore we should stop
caring about all active touchpoints.

The vast majority of such compositor guestures will already be caught by
touch_handle_motion(), but nothing stops a compositor from having "hold
for X seconds" as a valid gesture.
Sanify radius when finalizing bar
Implement string_container_get_string_or_else()

...to simplify having a default for values stored as a string container.

It allows to have a default without actually having an allocated string
container by default, meaning memory is only allocated if the value is
non-default.
Implement "namespace" config option

Some compositors may treat layerhsell surface differently based on their
namespace, therefore it needs to be configurable.
README: new example screenshot

This shows the new defaults and additionaly has the non-distracting
Adwaita icons.
Add Lava_string_container

This will slightly reduce memory usage when using "bar-copy".
ff57cd80 — Jan Beich 2 months ago
build: rename -Dman-page (singular) to -Dman-pages (plural)

Avoid typos when creating a package for this project using another
package as a template. Plural option name is more popular e.g.,

- cage
- grim
- gtk4
- kanshi
- libdrm
- seatd
- slurp
- swappy
- sway
- swaybg
- swayidle
- swaylock
- waybar
- waypipe
- wlogout
readme: Use repology badge
Next