Update cargo repo
The rust repo is at *-rs
Update cargo repo and categories
Small removal for clarification.
Prefer map() and fold()
I think it's more readable.
Better constraint on deps
Correct tests to be runnable in no_std where possible
Use the ascii crate for std Strings, too
It's still easier this way since callsigns are meant to be ascii only
Convert to using the ascii crate
Callsigns are only ever in ascii, so this is safe and allows me a way to do uppercase() in [no_std]
Add flags in appropriate places
Introduce std feature
follow serde's example, using:
- positive feature naming
- defaulting to some on
this allows no_std to be a thing, while still defaulting to using std
Prefer printing the padded int
The format for a callpass should always be 5 numbers long, padded if necessary.
Whoops, another straggler docs correction.
Change repo URL to new location
awwww a straggler docs correction
Better docs is good reason for a patch bump right?
Using the doctest comments leads to more clear examples, and I can isolate explanations step by step.