~kaction/config

8dd1582bee8540af28022a31cd652d28a5563e57 — Dmitry Bogatov 2 months ago 0e5b489
passphrase2pgp: use version from upstream

Now since we are doing nixpkgs mix-and-matching (which is probably going
to result in bloated derivation), there is no reason to keep around
derivations that were upstreamed.
2 files changed, 1 insertions(+), 14 deletions(-)

M flake.nix
D universe/passphrase2pgp/default.nix
M flake.nix => flake.nix +1 -2
@@ 67,7 67,7 @@
        in pkgs // pristine // rebuilded // { # nixfmt: sort
          inherit (pkgs.pkgsStatic) execline;
          inherit system;
          inherit (future') terraform;
          inherit (future') terraform passphrase2pgp;

          Documentation =
            callPackage ./universe/Documentation { inherit nixpkgs; };


@@ 89,7 89,6 @@

          nix = pkgs.nixFlakes;

          passphrase2pgp = call ./universe/passphrase2pgp;
          posixrc = callPackage ./universe/posixrc { };
          psql = pkgs.postgresql_10;
          rewrite-paths =

D universe/passphrase2pgp/default.nix => universe/passphrase2pgp/default.nix +0 -12
@@ 1,12 0,0 @@
{ lib, buildGoModule, fetchFromGitHub }:
buildGoModule rec {
  pname = "passphrase2pgp";
  version = "1.1.0";
  src = fetchFromGitHub {
    owner = "skeeto";
    repo = pname;
    rev = "v${version}";
    hash = "sha256-Nje77tn55CKRU6igEA/6IquDhXVVQAdiez6nmN49di4";
  };
  vendorSha256 = "sha256-7q5nwkj4TP7VgHmV9YBbCB11yTPL7tK4gD+uN4Vw3Cs";
}