Set up flake, with options for ape-loader
Initial commit
This Nix Flake is about integrating Cosmopolitan Libc, the build-once run-anywhere C library, with Nix.
You can build packages directly using nix build
in the usual way.
Add cosmo-nix
to your inputs
:
inputs.cosmo-nix = {
url = "sourcehut:~jack/cosmo.nix";
inputs.nixpkgs.follows = "nixpkgs";
};
If you use flake-parts
and/or Cachix's
git-hooks
, you should
override those inputs too.
We provide nixpkgs Overlays
that declare the packages exposed in the .#packages
output, and a
NixOS Module to configure the
APE loader to run
αcτµαlly pδrταblε εxεcµταblεs on NixOS.
packages.aarch64-linux.ape-loader
APE Loader (AArch64 edition).
packages.x86_64-linux.ape-loader
APE Loader (x86-64 edition).
overlays.default
All other overlays provided by this flake, merged together.
overlays.ape-loader
Provides the ape-loader
package.
nixosModules.default
All other NixOS modules provided by this flake, merged together.
nixosModules.ape-loader
Provides options to register the APE loader with
binfmt_misc
XOR patch your kernel so it
recognises APEs within binfmt_elf
.
#nix
.