~hristoast/hristoast

5cfddf48bf9bc2fe8c240c6809e9efdf659cd41a — Hristos N. Triantafillou 2 years ago 5e74d9f
Mesa updated to 19.3-rc4
1 files changed, 3 insertions(+), 3 deletions(-)

M site/xbps.html
M site/xbps.html => site/xbps.html +3 -3
@@ 22,7 22,7 @@

<ul>
  <li><code>linux-fsync</code> including <a href="https://aur.archlinux.org/cgit/aur.git/plain/futex-wait-multiple-5.2.1.patch?h=linux-fsync">this futex patch</a> (<a href="https://github.com/hristoast/void-packages/tree/linux-fsync/srcpkgs/linux-fsync">package template</a>)</li>
  <li>Mesa built from the <a href="https://github.com/daniel-schuermann/mesa/tree/2e64afa5e39823e6bbd53d775ed93fb2fabf1554">ACO branch</a> as <a href="https://steamcommunity.com/games/221410/announcements/detail/1602634609636894200">advertised by Valve</a> (<a href="https://github.com/hristoast/void-packages/tree/mesa-aco/srcpkgs/libGL">package template</a>).  Including:
  <li>Mesa dev pre-release builds which have experimental new features (<a href="https://github.com/hristoast/void-packages/tree/mesa-aco/srcpkgs/libGL">package template</a>).  Including packages:
    <ul>
      <li><code>MesaLib-devel</code></li>
      <li><code>libEGL</code></li>


@@ 46,14 46,14 @@
<h3>Installing Packages</h3>

<p>
  Packages can be installed the way any other package is installed, with the exception of Mesa and friends (see below).
  Packages can be installed and updated the way any other package is installed or updated, with the exception of Mesa and friends (see below).
</p>

<h3>Installing Mesa</h3>

<p>To install the Mesa packages, use this command:</p>

<pre><code>sudo xbps-install MesaLib-devel-20.0.0_aco1 libEGL-20.0.0_aco1 libGL-20.0.0_aco1 libGLES-20.0.0_aco1 libOSMesa-20.0.0_aco1 libgbm-20.0.0_aco1 libglapi-20.0.0_aco1 libxatracker-20.0.0_aco1 mesa-ati-dri-20.0.0_aco1 mesa-intel-dri-20.0.0_aco1 mesa-nouveau-dri-20.0.0_aco1 mesa-opencl-20.0.0_aco1 mesa-vmwgfx-dri-20.0.0_aco1</code></pre>
<pre><code>sudo xbps-install MesaLib-devel-19.3_rc4 libEGL-19.3_rc4 libGL-19.3_rc4 libGLES-19.3_rc4 libOSMesa-19.3_rc4 libgbm-19.3_rc4 libglapi-19.3_rc4 libxatracker-19.3_rc4 mesa-ati-dri-19.3_rc4 mesa-intel-dri-19.3_rc4 mesa-nouveau-dri-19.3_rc4 mesa-opencl-19.3_rc4 mesa-vmwgfx-dri-19.3_rc4</code></pre>

<p>The packages need to be installed all at once, or else they will fail to install due to version conflicts.</p>