~homeworkprod/byceps

ref: 3beaa96d910b36c05dfa41af8f22073a10dcab53 byceps/.travis.yml -rw-r--r-- 462 bytes
3beaa96d — Jochen Kupperschmidt PostgreSQL v9.6 is only available as of Ubuntu Trusty, but not yet on Ubuntu Precise 4 years ago
                                                                                
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
language: python
python:
  - "3.4"
  - "3.5"
  - "3.6"
addons:
  postgresql: "9.6"
  apt:
    packages:
      - language-pack-de
services:
  - redis-server
install:
  - "pip install --upgrade pip"
  - "pip install psycopg2"
before_script:
  - psql -U postgres -c "CREATE DATABASE byceps_test;"
  - psql -U postgres -c "CREATE ROLE byceps_test WITH LOGIN PASSWORD 'test';"
script:
  - "python setup.py test"
dist: trusty
sudo: false
notifications:
  email: false