~homeworkprod/byceps

ref: 533662eefb314d54b168e5a46bc07c88b5f88be4 byceps/.travis.yml -rw-r--r-- 768 bytes
d35e9b9b — Jochen Kupperschmidt 11 months ago
Cache dependencies downloaded via pip on Travis CI
e5d6c69e — Jochen Kupperschmidt 11 months ago
Follow Travis CI build config validation warnings and infos
4a04126f — Jochen Kupperschmidt 1 year, 2 months ago
Call Discord webhook after Travis CI build
a880d215 — Jochen Kupperschmidt 1 year, 5 months ago
Test on Travis CI with PostgreSQL v11 instead of v9.6

v11 is the default PostgreSQL version that comes with Debian "Buster" 10.
ca7ee721 — Jochen Kupperschmidt 1 year, 5 months ago
Install only test but not other development dependencies for CI test runs
cb248f15 — Jochen Kupperschmidt 1 year, 5 months ago
Avoid redundant installation of unpinned pytest version
2b3f64bb — Jochen Kupperschmidt 2 years ago
Use merged requirements file to obtain test dependencies on Travis CI
1dd4cdcb — Jochen Kupperschmidt 2 years ago
Use Ubuntu Bionic (instead of Trusty) on Travis CI to get Pythion 3.7 working
ca564341 — Jochen Kupperschmidt 2 years ago
Raise required Python version to 3.7 (from 3.6)

This makes data classes available.
a65c881d — Jochen Kupperschmidt 2 years ago
Adjust Travis CI config to explicitly install dependencies before running tests
651438c0 — Jochen Kupperschmidt 2 years ago
Adjust Travis CI config to run `pytest` now
053c56db — Jochen Kupperschmidt 2 years ago
Raise required Python version to 3.6 (from 3.5)
11b6fa42 — Jochen Kupperschmidt 3 years ago
Use 'psycopg2' binary installed via pip on Travis CI, too
7899f530 — Jochen Kupperschmidt 3 years ago
Raise minimum required Python version from 3.4 to 3.5
43bf3630 — Jochen Kupperschmidt 3 years ago
Upgrade pytest on Travis CI to get v3.3 rather than v3.0 provided by default
3beaa96d — Jochen Kupperschmidt 4 years ago
PostgreSQL v9.6 is only available as of Ubuntu Trusty, but not yet on Ubuntu Precise
5c734749 — Jochen Kupperschmidt 4 years ago
Upgrade to PostgreSQL v9.6 now that it became available in Debian's `jessie-backports` repository
c530c718 — Jochen Kupperschmidt 4 years ago
Test on Python 3.6, too
bf132704 — Jochen Kupperschmidt 5 years ago
Update pip itself before installing other packages with it.
8df388ba — Jochen Kupperschmidt 5 years ago
Adjusted overlooked Travis CI configuration file to moved files.
Next