~homeworkprod/byceps

ca564341fb85c2210e058df574ce76c57becd6f9 — Jochen Kupperschmidt 2 years ago 47111c5
Raise required Python version to 3.7 (from 3.6)

This makes data classes available.
3 files changed, 2 insertions(+), 3 deletions(-)

M .travis.yml
M docs/installation.rst
M setup.py
M .travis.yml => .travis.yml +1 -1
@@ 1,6 1,6 @@
language: python
python:
  - "3.6"
  - "3.7"
addons:
  postgresql: "9.6"
  apt:

M docs/installation.rst => docs/installation.rst +1 -1
@@ 5,7 5,7 @@ Installation
Requirements
------------

* Python_ 3.6 or higher
* Python_ 3.7 or higher
* PostgreSQL_ 9.6 or higher
* Redis_ 2.8 or higher


M setup.py => setup.py +0 -1
@@ 30,7 30,6 @@ setup(
        'Programming Language :: JavaScript',
        'Programming Language :: Python',
        'Programming Language :: Python :: 3',
        'Programming Language :: Python :: 3.6',
        'Programming Language :: Python :: 3.7',
        'Programming Language :: Python :: 3 :: Only',
        'Topic :: Communications',