~homeworkprod/byceps

053c56db3e57a7548773cae5384919889d898bf6 — Jochen Kupperschmidt 2 years ago df2f2ec
Raise required Python version to 3.6 (from 3.5)
4 files changed, 2 insertions(+), 4 deletions(-)

M .travis.yml
M docs/installation.rst
M setup.py
M tox.ini
M .travis.yml => .travis.yml +0 -1
@@ 1,6 1,5 @@
language: python
python:
  - "3.5"
  - "3.6"
addons:
  postgresql: "9.6"

M docs/installation.rst => docs/installation.rst +1 -1
@@ 5,7 5,7 @@ Installation
Requirements
------------

* Python_ 3.5.3 or higher
* Python_ 3.6 or higher
* PostgreSQL_ 9.6 or higher
* Redis_ 2.8 or higher


M setup.py => setup.py +0 -1
@@ 30,7 30,6 @@ setup(
        'Programming Language :: JavaScript',
        'Programming Language :: Python',
        'Programming Language :: Python :: 3',
        'Programming Language :: Python :: 3.5',
        'Programming Language :: Python :: 3.6',
        'Programming Language :: Python :: 3.7',
        'Programming Language :: Python :: 3 :: Only',

M tox.ini => tox.ini +1 -1
@@ 1,5 1,5 @@
[tox]
envlist = py35,py36
envlist = py36

[testenv]
commands = pytest