~glacambre/firenvim

fa6406dc642e1ca5d63ba414398e983256ccbddb — glacambre 2 years ago f62386a
Update editor-adapter

This fixes CSP issues thanks to the change I made to editor-adapter in
v0.0.3.

Closes #811
2 files changed, 9 insertions(+), 17 deletions(-)

M package-lock.json
M package.json
M package-lock.json => package-lock.json +8 -16
@@ 18,7 18,7 @@
        "addons-linter": "^3.13.0",
        "codemirror": "^5.62.3",
        "copy-webpack-plugin": "9.0.1",
        "editor-adapter": "^0.0.2",
        "editor-adapter": "^0.0.3",
        "imports-loader": "^3.0.0",
        "istanbul-lib-coverage": "^3.0.0",
        "jest": "27.0.6",


@@ 3223,12 3223,6 @@
      "engines": [
        "node >=0.10.0"
      ],
      "dependencies": {
        "dtrace-provider": "~0.8",
        "moment": "^2.19.3",
        "mv": "~2",
        "safe-json-stringify": "~1"
      },
      "bin": {
        "bunyan": "bin/bunyan"
      },


@@ 4650,9 4644,9 @@
      }
    },
    "node_modules/editor-adapter": {
      "version": "0.0.2",
      "resolved": "https://registry.npmjs.org/editor-adapter/-/editor-adapter-0.0.2.tgz",
      "integrity": "sha512-OnlrAq2MoLtclY/H2L9aArGNOEXfuKdRG2+h3QoFQZ2a7ea62UJlaeUUwfqdv6q7fDGAb8k7IK3X09/qUwJ2eg==",
      "version": "0.0.3",
      "resolved": "https://registry.npmjs.org/editor-adapter/-/editor-adapter-0.0.3.tgz",
      "integrity": "sha512-RxvdgL9Jj9TRwM/LIktwbtnmEHfsP1N0m9rrlfEtkZ0G1M6acYhgAAMiZBu/w+jyvAzC2jox77uryw5uNJQ64Q==",
      "dependencies": {
        "typescript": "^4.3.5"
      }


@@ 4807,8 4801,7 @@
        "esprima": "^4.0.1",
        "estraverse": "^5.2.0",
        "esutils": "^2.0.2",
        "optionator": "^0.8.1",
        "source-map": "~0.6.1"
        "optionator": "^0.8.1"
      },
      "bin": {
        "escodegen": "bin/escodegen.js",


@@ 8267,7 8260,6 @@
        "@types/node": "*",
        "anymatch": "^3.0.3",
        "fb-watchman": "^2.0.0",
        "fsevents": "^2.3.2",
        "graceful-fs": "^4.2.4",
        "jest-regex-util": "^27.0.6",
        "jest-serializer": "^27.0.6",


@@ 18421,9 18413,9 @@
      }
    },
    "editor-adapter": {
      "version": "0.0.2",
      "resolved": "https://registry.npmjs.org/editor-adapter/-/editor-adapter-0.0.2.tgz",
      "integrity": "sha512-OnlrAq2MoLtclY/H2L9aArGNOEXfuKdRG2+h3QoFQZ2a7ea62UJlaeUUwfqdv6q7fDGAb8k7IK3X09/qUwJ2eg==",
      "version": "0.0.3",
      "resolved": "https://registry.npmjs.org/editor-adapter/-/editor-adapter-0.0.3.tgz",
      "integrity": "sha512-RxvdgL9Jj9TRwM/LIktwbtnmEHfsP1N0m9rrlfEtkZ0G1M6acYhgAAMiZBu/w+jyvAzC2jox77uryw5uNJQ64Q==",
      "requires": {
        "typescript": "^4.3.5"
      }

M package.json => package.json +1 -1
@@ 10,7 10,7 @@
    "addons-linter": "^3.13.0",
    "codemirror": "^5.62.3",
    "copy-webpack-plugin": "9.0.1",
    "editor-adapter": "^0.0.2",
    "editor-adapter": "^0.0.3",
    "imports-loader": "^3.0.0",
    "istanbul-lib-coverage": "^3.0.0",
    "jest": "27.0.6",