Replace inaccurate guiSelectNote with guiSelectCard
`guiSelectNote` actually requires a card ID.
In order to keep supporting any users who have discovered this and already rely
on it, the old action is kept for compatibility, but left undocumented.
Fix overlooked util batches
Use generator-based batch function
Batches fetching notes' cards and cards' reviews
fix payload to match expected content
Add SetDueDate() and update notesInfo()
Relax required anki version
Replace duplicate code with call to addMediaFromNote
Fix year component of Anki version
Make string an f-string
so the directives within the string will get evaluated.
Use non-deprecated snake case names of collection methods
Replace calls to deprecated flush() with col.update_note/card
The changes passes skip_undo_entry to update_note/card, because the
implementation of the deprecated flush() method did so. Whether this is the
right decision for our use case was not checked/thought about.
Switch from deprecated names of anki/utils.py functions
Remove calls to deprecated (and empty) method autosave
Require current Anki version