~fkooman/vpn-maint-scripts

ref: 1.2.0 vpn-maint-scripts/bin/vpn-maint-update-node -rwxr-xr-x 531 bytes
ed277a5eFrançois Kooman update CHANGES 2 years ago
                                                                                
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
#!/bin/sh

if ! [ "root" = "$(id -u -n)" ]; then
    echo "ERROR: ${0} must be run as root!"; exit 1
fi

if [ -f /etc/fedora-release ]; then
    dnf -y --refresh update
elif [ -f /etc/centos-release ] || [ -f /etc/redhat-release ]; then
    yum clean expire-cache
    yum -y update
elif [ -f /etc/debian_version ]; then
    apt-get update
    # debconf(7)
    DEBIAN_FRONTEND=noninteractive apt-get -y dist-upgrade
else 
    echo "ERROR: OS not supported!"
    exit 1
fi

rm -rf /etc/openvpn/server/*
vpn-server-node-server-config