ui/app: support 0 for window width and height

The zero value means that the client don't care and a sensible
default is chosen.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: add package documentation and document Main

Split Main into the common Main function and platform specific
main functions.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: update documentation

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui: expand package documentation

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui: expose internal Ops fields as methods

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui: document types and methods

Signed-off-by: Elias Naur <mail@eliasnaur.com>
apps/gophers: update to latest gio

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: rename DrawEvent to UpdateEvent and Window.Draw to Window.Update

Window.Draw is not the right name for a method that does more than
just drawing. Rename to Update instead, and rename the DrawEvent
accordingly for symmetry.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
apps/gophers: delete unused fields and arguments

Signed-off-by: Elias Naur <mail@eliasnaur.com>
apps: update gioui.org/ui version

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/paint: rename the draw package

The draw package name clashes with the standard library draw package.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
all: remove exported Decode methods on operations

Add decode functions to the packages that need them instead. For
TransformOp that is used in multiple packages, add the decode
function to the internal ops package.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
app/internal/gpu: rename opClip to clipOp

To better match ClipOp, which was renamed from OpClip.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
all: add missing licence headers

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui,internal/ops,internal/opconst: move OpsReader to internal ops package

To avoid import cycles, move the op constants to its own package,
internal/opconst.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui: rename TransformOp.Mul to Multiply and split InvTransform

Multiply is a bit longer but more clear. InvTransform was really
two operations: Invert and Transform.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui: fix TransformOp.Offset

Signed-off-by: Elias Naur <mail@eliasnaur.com>
cmd/gio: clarify usage summary

Signed-off-by: Elias Naur <mail@eliasnaur.com>
cmd/gio: simplify -o flag description

Only mention the special case for iOS simulators.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
draw: Fix spelling of Bezier

Sometimes it was "bezier", sometimes "beziér".  Capitalize and put
accent on first e.  https://en.wikipedia.org/wiki/Bézier_curve

Signed-off-by: Larry Clapp <larry@theclapp.org>
Next