debug #35

Signed-off-by: Elias Naur <mail@eliasnaur.com>
apps: update gio version

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: print sRGB flag for eglCreateWindowSurface failure

For gio#35

Signed-off-by: Elias Naur <mail@eliasnaur.com>
apps: update gio version

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: (wayland) define WL_EGL_PLATFORM=1 to force EGL in Wayland mode

Including wayland-egl.h will also set WL_EGL_PLATFORM, but generic
egl code in egl_linux.go cannot do that.

For gio#35

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: (wayland) ensure DestroyEvent is the last event

A ToplevelClose event could end in the same batch of events as
another event, which will result in the other event being sent
after a DestroyEvent. Window assumes no event will arrive after
DestroyEvent, so ensure that property for the Wayland backend.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/layout: avoid accumulating rounding errors from Flexible

Signed-off-by: Elias Naur <mail@eliasnaur.com>
apps/gophers: update gio version

Signed-off-by: Elias Naur <mail@eliasnaur.com>
all: rename layout.Dimens to layout.Dimensions

Dimens is only 4 characters shorter and not worth the abbreviation.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
README.md: add donations section

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: (wayland) expand comments for double server roundtrip

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: fix example code in document

Signed-off-by: Kenshi Kamata <kenshi.kamata@gmail.com>
README.md: add link to Gophercon 2019 recording

Signed-off-by: Elias Naur <mail@eliasnaur.com>
website: require Go 1.12

Signed-off-by: Elias Naur <mail@eliasnaur.com>
website: add shortcuts for issues, commits and patches

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app: merge goString implementations and add test

Fixes gio#30

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/internal/ops: go fmt

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/key,ui/pointer: rename HandlerOp to InputOp

"Input" is more specific and reads better than "handler".

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui/app(internal/gpu: remove unused parameters

Signed-off-by: Elias Naur <mail@eliasnaur.com>
all: remove a couple of unused parameters

Both from unexported functions, to keep the change low-risk. Found via
unparam.

Signed-off-by: Daniel Martí <mvdan@mvdan.cc>
Next