ref: 284659d3eac9 gio/unit d---------
all: make unit.Converter concrete and rename to Metric

An interface for scaling dp and sp is overkill, at least for all
current uses. Make it a concrete struct type, and rename it to the
shorter and more precise Metric.

Signed-off-by: Elias Naur <mail@eliasnaur.com>
ui: fix wrong method name in documentation

Signed-off-by: Fabian Geiselhart <me@f4814n.de>
unit: add Value.Scale method

Signed-off-by: Elias Naur <mail@eliasnaur.com>
all: rename package ui to unit

Package ui is now only about units except for the Config.Now method.
Remove Now and rename Config to Converter. Add layout.Config to
replace the old ui.Config.

Signed-off-by: Elias Naur <mail@eliasnaur.com>