~eliasnaur/gio

fc7c5c13f4fb128f69bdd3c7c4b90d6801e809ba — Elias Naur 2 years ago 3b8cbc6
README.md: add EGL development package to Linux requirements

Updates ~eliasnaur/gio#3

Signed-off-by: Elias Naur <mail@eliasnaur.com>
1 files changed, 3 insertions(+), 3 deletions(-)

M README.md
M README.md => README.md +3 -3
@@ 14,14 14,14 @@ to support efficient animations, transformed drawing and pixel resolution indepe
Gio is designed to work with very few dependencies. It depends only on the platform libraries for
window management, input and GPU drawing.

For Linux you need Wayland and the wayland, xkbcommon, GLES development packages. On Fedora 28 and newer,
For Linux you need Wayland and the wayland, xkbcommon, GLES, EGL development packages. On Fedora 28 and newer,
install the dependencies with the command

	$ sudo dnf install wayland-devel libxkbcommon-devel mesa-libGLES-devel
	$ sudo dnf install wayland-devel libxkbcommon-devel mesa-libGLES-devel mesa-libEGL-devel

On Ubuntu 18.04 and newer, use

	$ sudo apt install libwayland-dev libxkbcommon-dev libgles2-mesa-dev
	$ sudo apt install libwayland-dev libxkbcommon-dev libgles2-mesa-dev libegl1-mesa-dev

Xcode is required for macOS, iOS, tvOS.