~efraim/guix

eb6a46fcb7e96b0a97dede35a6a7d54b3f63f34d — Igor Goryachev via Guix-patches via a month ago 13b15c5
gnu: erlang-jose: Relax build options.

* gnu/packages/erlang-xyz.scm (erlang-jose): Relax build options.

Change-Id: I0e90cb54558260aea07bc33a11a2ab56261a20bf
Signed-off-by: Andrew Tropin <andrew@trop.in>
1 files changed, 12 insertions(+), 0 deletions(-)

M gnu/packages/erlang-xyz.scm
M gnu/packages/erlang-xyz.scm => gnu/packages/erlang-xyz.scm +12 -0
@@ 59,6 59,18 @@
       (sha256
        (base32 "0576jdjygby37qmzrs8cm5l6n622b0mi3z28j6r4s5xsz1px6v0d"))))
    (build-system rebar-build-system)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          ;; Do not treat warnings as errors, for more info see:
          ;; https://github.com/potatosalad/erlang-jose/issues/168
          (add-after 'unpack 'relax-build-options
            (lambda _
              (substitute* "rebar.config"
                (("debug_info,") "debug_info"))
              (substitute* "rebar.config"
                (("warnings_as_errors") "")))))))
    (synopsis
     "JSON Object Signing and Encryption for Erlang and Elixir")
    (description