~cypheon/elfelli

ref: ad485aa8d8504cb098113e87da206866652e3fc5 elfelli/.travis.yml -rw-r--r-- 523 bytes
ad485aa8 — Johann Rudloff Require CMake >= 3.12, install cmake via brew in macOS Travis build. 1 year, 8 months ago
                                                                                
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
language: cpp

os:
  - linux
  - osx

env:
  # (default) build using CMake
  - USE_SCONS=
  # (deprecated) build using SCons
  - USE_SCONS=yes

addons:
  apt:
    packages:
      - scons
      - libgtkmm-2.4-dev
      - librsvg2-bin
      - librsvg2-dev

before_install:
  - if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then brew update; fi
  - if [[ "$TRAVIS_OS_NAME" == "osx" ]]; then brew install cmake gettext gtkmm librsvg scons; fi

before_script:
  - export PATH=$PATH:/usr/local/opt/gettext/bin/

script:
  - ./ci/build.sh