~cedric/newspipe

edbaad2d204e3efccbd542ec7ae37d396e648137 — Cédric Bonhomme 8 years ago c517765
Updated README.
2 files changed, 10 insertions(+), 7 deletions(-)

M README.md
M docs/index.rst
M README.md => README.md +6 -4
@@ 29,11 29,13 @@ Requierements

Software required

* [Python](http://python.org/) >= 3.2.3;
* [Python](http://python.org/) >= 3.2;
* [MongoDB](http://www.mongodb.org/) and [PyMongo](http://api.mongodb.org/python/current/) >= 1.9;
* [feedparser](http://code.google.com/p/feedparser/) >= 5.1.2 (for **feedgetter.py**, the RSS feed parser);
* [CherryPy](http://cherrypy.org/) >= 3.2.2 and [Mako](http://www.makotemplates.org/) (for **pyAggr3g470r.py**, the Web interface);
* [BeautifulSoup](http://www.crummy.com/software/BeautifulSoup/) >= 4.1.3 (automatically find a feed in a HTML page).
* [BeautifulSoup](http://www.crummy.com/software/BeautifulSoup/) >= 4.1.2 (automatically find a feed in a HTML page).

Python 3.3 is recommend for better performances with large collections.

Optional module



@@ 43,9 45,9 @@ These modules are not required but enables more features:
* lxml and Genshi;
* Python Imaging Library for the generation of QR codes.

Not yet tested with Python 3.2. Anyway, if you want to install these modules:
Not yet tested with Python 3.3. Anyway, if you want to install these modules:

    $ sudo aptitude install python3.2-lxml python-genshi
    $ sudo aptitude install python3.3-lxml python-genshi

Backup
------

M docs/index.rst => docs/index.rst +4 -3
@@ 37,12 37,13 @@ Requierements
Software required
`````````````````

* Python_ >= 3.3;
* Python_ >= 3.2;
* MongoDB_ and PyMongo_ >= 1.9;
* feedparser_ >= 5.1.2 (for **feedgetter.py**, the RSS feed parser);
* CherryPy_ >= 3.2.4 and Mako_ (for **pyAggr3g470r.py**, the Web interface);
* BeautifulSoup_ >= 4.1.3 (automatically find a feed in a HTML page).
* BeautifulSoup_ bs4 >= 4.1.2 (automatically find a feed in a HTML page).

Python 3.3 is recommend for better performances with large collections.

Optional module
```````````````


@@ 92,7 93,7 @@ Script of installation
    cd pyaggr3g470r/source/
    cp cfg/pyAggr3g470r.cfg-sample cfg/pyAggr3g470r.cfg

This script works with Python 3.2.
This script works with Python 3.3.


Setting