~cedric/newspipe

b61d13c2bc0abf20cfea392b7bb0defaae280e3a — Cédric Bonhomme 20 days ago 816e5b7
Updated feedparser
2 files changed, 185 insertions(+), 177 deletions(-)

M poetry.lock
M pyproject.toml
M poetry.lock => poetry.lock +184 -176
@@ 1,10 1,10 @@
[[package]]
category = "main"
description = "Async http client/server framework (asyncio)"
name = "aiohttp"
version = "3.7.3"
description = "Async http client/server framework (asyncio)"
category = "main"
optional = false
python-versions = ">=3.6"
version = "3.7.3"

[package.dependencies]
async-timeout = ">=3.0,<4.0"


@@ 18,124 18,125 @@ yarl = ">=1.0,<2.0"
speedups = ["aiodns", "brotlipy", "cchardet"]

[[package]]
category = "main"
description = "A database migration tool for SQLAlchemy."
name = "alembic"
version = "1.4.3"
description = "A database migration tool for SQLAlchemy."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "1.4.3"

[package.dependencies]
Mako = "*"
SQLAlchemy = ">=1.1.0"
python-dateutil = "*"
python-editor = ">=0.3"
SQLAlchemy = ">=1.1.0"

[[package]]
category = "main"
description = "A library for parsing ISO 8601 strings."
name = "aniso8601"
version = "8.1.0"
description = "A library for parsing ISO 8601 strings."
category = "main"
optional = false
python-versions = "*"
version = "8.1.0"

[[package]]
category = "main"
description = "Timeout context manager for asyncio programs"
name = "async-timeout"
version = "3.0.1"
description = "Timeout context manager for asyncio programs"
category = "main"
optional = false
python-versions = ">=3.5.3"
version = "3.0.1"

[[package]]
category = "main"
description = "Classes Without Boilerplate"
name = "attrs"
version = "20.3.0"
description = "Classes Without Boilerplate"
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "20.3.0"

[package.extras]
dev = ["coverage (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "zope.interface", "furo", "sphinx", "pre-commit"]
dev = ["coverage[toml] (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "zope.interface", "furo", "sphinx", "pre-commit"]
docs = ["furo", "sphinx", "zope.interface"]
tests = ["coverage (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "zope.interface"]
tests_no_zope = ["coverage (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six"]
tests = ["coverage[toml] (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six", "zope.interface"]
tests_no_zope = ["coverage[toml] (>=5.0.2)", "hypothesis", "pympler", "pytest (>=4.3.0)", "six"]

[[package]]
category = "main"
description = "Internationalization utilities"
name = "babel"
version = "2.9.0"
description = "Internationalization utilities"
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "2.9.0"

[package.dependencies]
pytz = ">=2015.7"

[[package]]
category = "main"
description = "Screen-scraping library"
name = "beautifulsoup4"
version = "4.9.3"
description = "Screen-scraping library"
category = "main"
optional = false
python-versions = "*"
version = "4.9.3"

[package.dependencies]
[package.dependencies.soupsieve]
python = ">=3.0"
version = ">1.2"
soupsieve = {version = ">1.2", markers = "python_version >= \"3.0\""}

[package.extras]
html5lib = ["html5lib"]
lxml = ["lxml"]

[[package]]
category = "main"
description = "Fast, simple object-to-object and broadcast signaling"
name = "blinker"
version = "1.4"
description = "Fast, simple object-to-object and broadcast signaling"
category = "main"
optional = false
python-versions = "*"
version = "1.4"

[[package]]
category = "main"
description = "Python package for providing Mozilla's CA Bundle."
name = "certifi"
version = "2020.11.8"
description = "Python package for providing Mozilla's CA Bundle."
category = "main"
optional = false
python-versions = "*"
version = "2020.11.8"

[[package]]
category = "main"
description = "Universal encoding detector for Python 2 and 3"
name = "chardet"
version = "3.0.4"
description = "Universal encoding detector for Python 2 and 3"
category = "main"
optional = false
python-versions = "*"
version = "3.0.4"

[[package]]
category = "main"
description = "Composable command line interface toolkit"
name = "click"
version = "7.1.2"
description = "Composable command line interface toolkit"
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
version = "7.1.2"

[[package]]
category = "main"
description = "Universal feed parser, handles RSS 0.9x, RSS 1.0, RSS 2.0, CDF, Atom 0.3, and Atom 1.0 feeds"
name = "feedparser"
version = "6.0.2"
description = "Universal feed parser, handles RSS 0.9x, RSS 1.0, RSS 2.0, CDF, Atom 0.3, and Atom 1.0 feeds"
category = "main"
optional = false
python-versions = "*"
version = "5.2.1"
python-versions = ">=3.6"

[package.dependencies]
sgmllib3k = "*"

[[package]]
category = "dev"
description = "the modular source code checker: pep8 pyflakes and co"
name = "flake8"
version = "3.8.4"
description = "the modular source code checker: pep8 pyflakes and co"
category = "dev"
optional = false
python-versions = "!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,>=2.7"
version = "3.8.4"

[package.dependencies]
mccabe = ">=0.6.0,<0.7.0"


@@ 143,18 144,18 @@ pycodestyle = ">=2.6.0a1,<2.7.0"
pyflakes = ">=2.2.0,<2.3.0"

[[package]]
category = "main"
description = "A simple framework for building complex web applications."
name = "flask"
version = "1.1.2"
description = "A simple framework for building complex web applications."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
version = "1.1.2"

[package.dependencies]
Jinja2 = ">=2.10.1"
Werkzeug = ">=0.15"
click = ">=5.1"
itsdangerous = ">=0.24"
Jinja2 = ">=2.10.1"
Werkzeug = ">=0.15"

[package.extras]
dev = ["pytest", "coverage", "tox", "sphinx", "pallets-sphinx-themes", "sphinxcontrib-log-cabinet", "sphinx-issues"]


@@ 162,12 163,12 @@ docs = ["sphinx", "pallets-sphinx-themes", "sphinxcontrib-log-cabinet", "sphinx-
dotenv = ["python-dotenv"]

[[package]]
category = "main"
description = "Adds i18n/l10n support to Flask applications"
name = "flask-babel"
version = "1.0.0"
description = "Adds i18n/l10n support to Flask applications"
category = "main"
optional = false
python-versions = "*"
version = "1.0.0"

[package.dependencies]
Babel = ">=2.3"


@@ 176,63 177,63 @@ Jinja2 = ">=2.5"
pytz = "*"

[[package]]
category = "main"
description = "User session management for Flask"
name = "flask-login"
version = "0.5.0"
description = "User session management for Flask"
category = "main"
optional = false
python-versions = "*"
version = "0.5.0"

[package.dependencies]
Flask = "*"

[[package]]
category = "main"
description = "SQLAlchemy database migrations for Flask applications using Alembic"
name = "flask-migrate"
version = "2.5.3"
description = "SQLAlchemy database migrations for Flask applications using Alembic"
category = "main"
optional = false
python-versions = "*"
version = "2.5.3"

[package.dependencies]
alembic = ">=0.7"
Flask = ">=0.9"
Flask-SQLAlchemy = ">=1.0"
alembic = ">=0.7"

[[package]]
category = "main"
description = "Simple paginate support for flask"
name = "flask-paginate"
version = "0.5.5"
description = "Simple paginate support for flask"
category = "main"
optional = false
python-versions = "*"
version = "0.5.5"

[package.dependencies]
Flask = "*"

[[package]]
category = "main"
description = "Identity management for flask"
name = "flask-principal"
version = "0.4.0"
description = "Identity management for flask"
category = "main"
optional = false
python-versions = "*"
version = "0.4.0"

[package.dependencies]
Flask = "*"
blinker = "*"
Flask = "*"

[[package]]
category = "main"
description = "Simple framework for creating REST APIs"
name = "flask-restful"
version = "0.3.8"
description = "Simple framework for creating REST APIs"
category = "main"
optional = false
python-versions = "*"
version = "0.3.8"

[package.dependencies]
Flask = ">=0.8"
aniso8601 = ">=0.82"
Flask = ">=0.8"
pytz = "*"
six = ">=1.3.0"



@@ 240,64 241,64 @@ six = ">=1.3.0"
docs = ["sphinx"]

[[package]]
category = "main"
description = "Adds SQLAlchemy support to your Flask application."
name = "flask-sqlalchemy"
version = "2.4.4"
description = "Adds SQLAlchemy support to your Flask application."
category = "main"
optional = false
python-versions = ">= 2.7, != 3.0.*, != 3.1.*, != 3.2.*, != 3.3.*"
version = "2.4.4"

[package.dependencies]
Flask = ">=0.10"
SQLAlchemy = ">=0.8.0"

[[package]]
category = "main"
description = "HTTP security headers for Flask."
name = "flask-talisman"
version = "0.7.0"
description = "HTTP security headers for Flask."
category = "main"
optional = false
python-versions = "*"
version = "0.7.0"

[package.dependencies]
six = ">=1.9.0"

[[package]]
category = "main"
description = "Simple integration of Flask and WTForms."
name = "flask-wtf"
version = "0.14.3"
description = "Simple integration of Flask and WTForms."
category = "main"
optional = false
python-versions = "*"
version = "0.14.3"

[package.dependencies]
Flask = "*"
WTForms = "*"
itsdangerous = "*"
WTForms = "*"

[[package]]
category = "main"
description = "Internationalized Domain Names in Applications (IDNA)"
name = "idna"
version = "2.10"
description = "Internationalized Domain Names in Applications (IDNA)"
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "2.10"

[[package]]
category = "main"
description = "Various helpers to pass data to untrusted environments and back."
name = "itsdangerous"
version = "1.1.0"
description = "Various helpers to pass data to untrusted environments and back."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "1.1.0"

[[package]]
category = "main"
description = "A very fast and expressive template engine."
name = "jinja2"
version = "2.11.2"
description = "A very fast and expressive template engine."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
version = "2.11.2"

[package.dependencies]
MarkupSafe = ">=0.23"


@@ 306,12 307,12 @@ MarkupSafe = ">=0.23"
i18n = ["Babel (>=0.8)"]

[[package]]
category = "main"
description = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
name = "lxml"
version = "4.6.2"
description = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, != 3.4.*"
version = "4.6.2"

[package.extras]
cssselect = ["cssselect (>=0.7)"]


@@ 320,12 321,12 @@ htmlsoup = ["beautifulsoup4"]
source = ["Cython (>=0.29.7)"]

[[package]]
category = "main"
description = "A super-fast templating language that borrows the  best ideas from the existing templating languages."
name = "mako"
version = "1.1.3"
description = "A super-fast templating language that borrows the  best ideas from the existing templating languages."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "1.1.3"

[package.dependencies]
MarkupSafe = ">=0.9.2"


@@ 335,118 336,117 @@ babel = ["babel"]
lingua = ["lingua"]

[[package]]
category = "main"
description = "Safely add untrusted strings to HTML/XML markup."
name = "markupsafe"
version = "1.1.1"
description = "Safely add untrusted strings to HTML/XML markup."
category = "main"
optional = false
python-versions = ">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*"
version = "1.1.1"

[[package]]
category = "dev"
description = "McCabe checker, plugin for flake8"
name = "mccabe"
version = "0.6.1"
description = "McCabe checker, plugin for flake8"
category = "dev"
optional = false
python-versions = "*"
version = "0.6.1"

[[package]]
category = "main"
description = "multidict implementation"
name = "multidict"
version = "5.1.0"
description = "multidict implementation"
category = "main"
optional = false
python-versions = ">=3.6"
version = "5.1.0"

[[package]]
category = "main"
description = "Lightweight OPML parsing."
name = "opml"
version = "0.5"
description = "Lightweight OPML parsing."
category = "main"
optional = false
python-versions = "*"
version = "0.5"

[package.dependencies]
lxml = "*"
setuptools = "*"

[[package]]
category = "main"
description = "psycopg2 - Python-PostgreSQL Database Adapter"
name = "psycopg2-binary"
version = "2.8.6"
description = "psycopg2 - Python-PostgreSQL Database Adapter"
category = "main"
optional = false
python-versions = ">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*"
version = "2.8.6"

[[package]]
category = "dev"
description = "Python style guide checker"
name = "pycodestyle"
version = "2.6.0"
description = "Python style guide checker"
category = "dev"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "2.6.0"

[[package]]
category = "dev"
description = "Python interface to Graphviz's Dot"
name = "pydot"
version = "1.4.1"
description = "Python interface to Graphviz's Dot"
category = "dev"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "1.4.1"

[package.dependencies]
pyparsing = ">=2.1.4"

[[package]]
category = "dev"
description = "passive checker of Python programs"
name = "pyflakes"
version = "2.2.0"
description = "passive checker of Python programs"
category = "dev"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "2.2.0"

[[package]]
category = "dev"
description = "Python parsing module"
name = "pyparsing"
version = "2.4.7"
description = "Python parsing module"
category = "dev"
optional = false
python-versions = ">=2.6, !=3.0.*, !=3.1.*, !=3.2.*"
version = "2.4.7"

[[package]]
category = "main"
description = "Extensions to the standard Python datetime module"
name = "python-dateutil"
version = "2.8.1"
description = "Extensions to the standard Python datetime module"
category = "main"
optional = false
python-versions = "!=3.0.*,!=3.1.*,!=3.2.*,>=2.7"
version = "2.8.1"

[package.dependencies]
six = ">=1.5"

[[package]]
category = "main"
description = "Programmatically open an editor, capture the result."
name = "python-editor"
version = "1.0.4"
description = "Programmatically open an editor, capture the result."
category = "main"
optional = false
python-versions = "*"
version = "1.0.4"

[[package]]
category = "main"
description = "World timezone definitions, modern and historical"
name = "pytz"
version = "2020.4"
description = "World timezone definitions, modern and historical"
category = "main"
optional = false
python-versions = "*"
version = "2020.4"

[[package]]
category = "main"
description = "Python HTTP for Humans."
name = "requests"
version = "2.25.0"
description = "Python HTTP for Humans."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
version = "2.25.0"

[package.dependencies]
certifi = ">=2017.4.17"


@@ 456,43 456,50 @@ urllib3 = ">=1.21.1,<1.27"

[package.extras]
security = ["pyOpenSSL (>=0.14)", "cryptography (>=1.3.4)"]
socks = ["PySocks (>=1.5.6,<1.5.7 || >1.5.7)", "win-inet-pton"]
socks = ["PySocks (>=1.5.6,!=1.5.7)", "win-inet-pton"]

[[package]]
category = "main"
description = "Asynchronous Python HTTP for Humans."
name = "requests-futures"
version = "1.0.0"
description = "Asynchronous Python HTTP for Humans."
category = "main"
optional = false
python-versions = "*"
version = "1.0.0"

[package.dependencies]
requests = ">=1.2.0"

[[package]]
name = "sgmllib3k"
version = "1.0.0"
description = "Py3k port of sgmllib."
category = "main"
description = "Python 2 and 3 compatibility utilities"
optional = false
python-versions = "*"

[[package]]
name = "six"
version = "1.15.0"
description = "Python 2 and 3 compatibility utilities"
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*"
version = "1.15.0"

[[package]]
category = "main"
description = "A modern CSS selector implementation for Beautiful Soup."
marker = "python_version >= \"3.0\""
name = "soupsieve"
version = "2.0.1"
description = "A modern CSS selector implementation for Beautiful Soup."
category = "main"
optional = false
python-versions = ">=3.5"
version = "2.0.1"

[[package]]
category = "main"
description = "Database Abstraction Library"
name = "sqlalchemy"
version = "1.3.20"
description = "Database Abstraction Library"
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*"
version = "1.3.20"

[package.extras]
mssql = ["pyodbc"]


@@ 507,57 514,56 @@ postgresql_psycopg2cffi = ["psycopg2cffi"]
pymysql = ["pymysql"]

[[package]]
category = "dev"
description = "Turn SQLAlchemy DB Model into a graph"
name = "sqlalchemy-schemadisplay"
version = "1.3"
description = "Turn SQLAlchemy DB Model into a graph"
category = "dev"
optional = false
python-versions = "*"
version = "1.3"

[package.dependencies]
pydot = "*"
setuptools = "*"

[[package]]
category = "main"
description = "Backported and Experimental Type Hints for Python 3.5+"
name = "typing-extensions"
version = "3.7.4.3"
description = "Backported and Experimental Type Hints for Python 3.5+"
category = "main"
optional = false
python-versions = "*"
version = "3.7.4.3"

[[package]]
category = "main"
description = "HTTP library with thread-safe connection pooling, file post, and more."
name = "urllib3"
version = "1.26.2"
description = "HTTP library with thread-safe connection pooling, file post, and more."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, <4"
version = "1.26.2"

[package.extras]
brotli = ["brotlipy (>=0.6.0)"]
secure = ["pyOpenSSL (>=0.14)", "cryptography (>=1.3.4)", "idna (>=2.0.0)", "certifi", "ipaddress"]
socks = ["PySocks (>=1.5.6,<1.5.7 || >1.5.7,<2.0)"]
socks = ["PySocks (>=1.5.6,!=1.5.7,<2.0)"]

[[package]]
category = "main"
description = "The comprehensive WSGI web application library."
name = "werkzeug"
version = "1.0.1"
description = "The comprehensive WSGI web application library."
category = "main"
optional = false
python-versions = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*"
version = "1.0.1"

[package.extras]
dev = ["pytest", "pytest-timeout", "coverage", "tox", "sphinx", "pallets-sphinx-themes", "sphinx-issues"]
watchdog = ["watchdog"]

[[package]]
category = "main"
description = "A flexible forms validation and rendering library for Python web development."
name = "wtforms"
version = "2.3.3"
description = "A flexible forms validation and rendering library for Python web development."
category = "main"
optional = false
python-versions = "*"
version = "2.3.3"

[package.dependencies]
MarkupSafe = "*"


@@ 568,21 574,21 @@ ipaddress = ["ipaddress"]
locale = ["Babel (>=1.3)"]

[[package]]
category = "main"
description = "Yet another URL library"
name = "yarl"
version = "1.6.3"
description = "Yet another URL library"
category = "main"
optional = false
python-versions = ">=3.6"
version = "1.6.3"

[package.dependencies]
idna = ">=2.0"
multidict = ">=4.0"

[metadata]
content-hash = "f5e5860ca483252734221f791fc859169287b8c691ab6ee15816f79794faabcd"
lock-version = "1.0"
lock-version = "1.1"
python-versions = "^3.8"
content-hash = "121224fc6d36f571a0d427809ff6d76bf2279643263eef5fed19d1b3d599a6f3"

[metadata.files]
aiohttp = [


@@ 665,9 671,8 @@ click = [
    {file = "click-7.1.2.tar.gz", hash = "sha256:d2b5255c7c6349bc1bd1e59e08cd12acbbd63ce649f2588755783aa94dfb6b1a"},
]
feedparser = [
    {file = "feedparser-5.2.1.tar.bz2", hash = "sha256:ce875495c90ebd74b179855449040003a1beb40cd13d5f037a0654251e260b02"},
    {file = "feedparser-5.2.1.tar.gz", hash = "sha256:bd030652c2d08532c034c27fcd7c85868e7fa3cb2b17f230a44a6bbc92519bf9"},
    {file = "feedparser-5.2.1.zip", hash = "sha256:cd2485472e41471632ed3029d44033ee420ad0b57111db95c240c9160a85831c"},
    {file = "feedparser-6.0.2-py3-none-any.whl", hash = "sha256:f596c4b34fb3e2dc7e6ac3a8191603841e8d5d267210064e94d4238737452ddd"},
    {file = "feedparser-6.0.2.tar.gz", hash = "sha256:1b00a105425f492f3954fd346e5b524ca9cef3a4bbf95b8809470e9857aa1074"},
]
flake8 = [
    {file = "flake8-3.8.4-py2.py3-none-any.whl", hash = "sha256:749dbbd6bfd0cf1318af27bf97a14e28e5ff548ef8e5b1566ccfb25a11e7c839"},


@@ 916,6 921,9 @@ requests = [
requests-futures = [
    {file = "requests-futures-1.0.0.tar.gz", hash = "sha256:35547502bf1958044716a03a2f47092a89efe8f9789ab0c4c528d9c9c30bc148"},
]
sgmllib3k = [
    {file = "sgmllib3k-1.0.0.tar.gz", hash = "sha256:7868fb1c8bfa764c1ac563d3cf369c381d1325d36124933a726f29fcdaa812e9"},
]
six = [
    {file = "six-1.15.0-py2.py3-none-any.whl", hash = "sha256:8b74bedcbbbaca38ff6d7491d76f2b06b3592611af620f8426e82dddb04a5ced"},
    {file = "six-1.15.0.tar.gz", hash = "sha256:30639c035cdb23534cd4aa2dd52c3bf48f06e5f4a941509c8bafd8ce11080259"},

M pyproject.toml => pyproject.toml +1 -1
@@ 11,7 11,6 @@ aiohttp = "^3.6.2"
requests = "^2.23.0"
chardet = "^3.0.4"
requests-futures = "^1.0.0"
feedparser = "^5.2.1"
beautifulsoup4 = "^4.8.2"
lxml = "^4.5.0"
opml = "^0.5"


@@ 30,6 29,7 @@ WTForms = "^2.2.1"
python-dateutil = "^2.8.1"
psycopg2-binary = "^2.8.4"
flask-talisman = "^0.7.0"
feedparser = "^6.0.2"