~ancarda/high-test-coverage

ref: 6f0007886977f90f075dc23aad6af6e9c58733f2 high-test-coverage/composer.json -rw-r--r-- 1.2 KiB
6f000788Mark Dain CI improvements and fixes 5 months ago
                                                                                
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
{
    "name": "ancarda/high-test-coverage",
    "description": "Classes and Interfaces to help you get higher test coverage",
    "type": "library",
    "license": "MIT",
    "config": {
        "platform": {
            "php": "7.3"
        },
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "Ancarda\\HighTestCoverage\\": "src"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "Tests\\": "tests"
        }
    },
    "require": {
        "php": "^7.3|^8.0"
    },
    "require-dev": {
        "ancarda/coverage-enforcer": "^1.0",
        "composer/package-versions-deprecated": "1.11.99.1",
        "infection/infection": "^0.18.2",
        "phpstan/phpstan": "^0.12.82",
        "phpstan/phpstan-phpunit": "^0.12.18",
        "phpstan/phpstan-strict-rules": "^0.12.9",
        "phpunit/phpunit": "^9.5",
        "squizlabs/php_codesniffer": "^3.5"
    },
    "scripts": {
        "analyze": "phpstan",
        "check-coverage": "enforce-coverage --minStmtCov 100 var/coverage/coverage.clover.xml",
        "check-style": "phpcs",
        "check-tests": "infection",
        "fix-style": "phpcbf",
        "test": "phpunit"
    }
}