~ancarda/coverage-enforcer

ref: 2664fd066d042ddc66573cc7ba665c0621ae1e97 coverage-enforcer/README.md -rw-r--r-- 408 bytes
2664fd06Mark Dain Flag as PHP 8.0 compatible 3 months ago

#Coverage Enforcer

Coverage Enforcer is a tiny command line tool that enforces code coverage metrics. Intended to be used in Continuous Integration (CI) systems to prevent code coverage from falling to unacceptable levels.

Pull down with composer:

composer require --dev ancarda/coverage-enforcer

Then just invoke like so:

vendor/bin/enforce-coverage --minStmtCov=100 <path to clover XML file>